1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug acp:store templates as files option: error messagen when creating new style

Discussion in 'Resolved Bug Reports' started by Marcus, Oct 22, 2011.

  1. Marcus

    Marcus Well-Known Member

    When I create a new style with the store templates as files option activated, I get this message:

     
  2. ragtek

    ragtek Guest

    the template directory have no permissions

    mike, kier shouldn't you throw here an error/notice so the users knows he have to set the permissions manual?

    PHP:
            protected function _createTemplateDirectory()
            {
                if (!
    is_dir($this->_path)) {
                    if (
    XenForo_Helper_File::createDirectory($this->_path)) {
                        return 
    XenForo_Helper_File::makeWritableByFtpUser($this->_path);
                    }
                    else
                    {
                        return 
    false;
                    }
                }

                return 
    true;
            }
     
  3. Marcus

    Marcus Well-Known Member

    Quick fix for everyone:

    make this folder 0775 writeable: /internal_data/templates
     
  4. Mike

    Mike XenForo Developer Staff Member

    You should never have to - it's a requirement that the internal_data directory itself is writable by the webserver. As such, I'm not sure why this would occur without that.

    Marcus, did you move servers or anything like that recently?
     
  5. Marcus

    Marcus Well-Known Member

    Today I activated CDN by pointing both domain.net as sub.domain.com to my forum domain.com, pointed these domains directly to /internal_data and first activated sub.domain.com and since then I use domain.net.

    I noticed this behavior short after. Ragtek pointed me to the directory permissions. Whenever I put permissions to 0775 it worked and when turned again to 0755 it did not work.

    Now it also works with 0755.
     
  6. Marcus

    Marcus Well-Known Member

    I reproduced this bug when creating a new template in debug to a custom addon.

    When creating the template I got this error message
    I disabled the acp>store template as files option
    I could create the new template in debug modus
    I enabled the acp>store template as files option
    I got this error message
    I changed directory permissions to 777
    It works
     
  7. bambua

    bambua Well-Known Member

    Depending on your server settings on some servers 755 won't work for the data directories you have to use 777 for them. I know on my server the webserver runs as nobody which means for data I have to go with 777, if it's running as a user, as long as that user is the owner of the files you can go with 755.
     
  8. Marcus

    Marcus Well-Known Member

    After a PLESK update today I experienced the same problem again. I changed permissions of internal data directory to 0777 it worked. I changed them back to 0755 and it works now.
     
  9. Marcus

    Marcus Well-Known Member

    The other parts of my internal_data directory can not be written to after my Plesk Update. Now I had to 0777 all these subforums and even the sub-subforums for the attachments.
     
    Adam Howard likes this.

Share This Page