1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 A Little Advice Please?

Discussion in 'Troubleshooting and Problems' started by Louise Williams, Jan 27, 2016.

  1. We have been running Xenforo pretty smoothly for 6 months after moving over from Vbulletin.

    Over the weekend something blew up and our site kind of fell apart (no fault of Xenforo) so currently I have an issue with new users not being able to register because there is some sort of conflict with a plugin, none of the plugins are working and I can't uninstall the plugins because our (now ex) webmaster appears to have had to do something to the code in various places to try to hack the whole thing back together.

    Our webmaster has always kept us going, but he is very much a fan of workarounds and doing things his way - so now we can't figure out how the heck to get back to normal.

    We migrated to a new server yesterday and have all the database files - so I have all the members, all the posts (the forum has been up over a decade and is pretty active so that is a lot of stuff) and I have a half working forum up.

    What I would like to know, is can I start over with a clean/fresh Xenforo? Set it up on the server and then import my members/posts/images/whatever? Without bringing over any of the code stuff he did that seems to be messing us up? And if yes, where do I start?

    Thanks so much for anyone with time to point me in the right direction - much appreciated!
  2. Brogan

    Brogan XenForo Moderator Staff Member

    You haven't explained what the problems are but disabling all add-ons and reverting to a default style should restore the site to default functionality.

    It should be possible to uninstall add-ons, you would need to explain the errors you receive when attempting to do so before we can offer any advice.
  3. The plugin causing the main issue (Social Groups) isn't even on the plugin page anymore - he seems to have weirdly coded it and around various things and then deleted part of it. He was very good at what he did - so no disrespect to him at all - but I am working with a very rudimentary knowledge and I was really hoping that there was a way for me to install a second instance of xenforo on my server and basically build a new forum with the same data, then turn off the old xenforo? (As I said - totally rudimentary so please do tell me if it simply doesn't work that way).
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Doing a new installation and an XF to XF import is really a last resort.

    There shouldn't be any reason why you can't uninstall the add-on and restore the site.
    Even if it means installing it again, just to uninstall it.

    Have you tried contacting the author of the add-on for assistance?
  5. I haven't and I will - that is a good idea thank you. But it isn't just this plugin that is concerning me - we also have Arrowchat installed on the forum and this has all been installed in a strange way and only part works, and I can't figure out how to take it off completely either - not to mention any other mods/changes he has made to the code in various places on top of this. I realise I am not being very helpful - all I know is I have a dozen bugs and conflicts and nothing is installed the way it 'should' be and he has altered the code to make "his way" work and I don't know squat about code so I haven't the first idea how to get back to the 'base' xenforo and start again.

    Is a new installation and an XF to XF import a last resort because it should be able to be fixed some other way, or because its really hard/a really bad idea in general?
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Two reasons really; it should be possible to restore the site without having to do that and doing an import will result in a loss of content, data and settings, stuff which isn't covered by the importer.
  7. Okay thank you - when you say loss of content do you mean I would lose members and posts etc? I don't mind having to put all the settings and permissions back on, but I can't lose any members or posts. Sorry for being really dim - but we imported all the members and posts when we moved from vbulletin without losing any - does it not work the same Xenforo to Xenforo?
  8. Brogan

    Brogan XenForo Moderator Staff Member

  9. Thank you I will look at putting a request there. So it is permissions/user groups etc I would lose, not my actual forum content? I just want to be sure I have all the information I need to be able to best advise the other stakeholders. I really appreciate your time and help - thanks!
  10. Brogan

    Brogan XenForo Moderator Staff Member

    In terms of content, this is what would be imported.


    As I say though, it's really a last resort and it should be possible to restore the site without having to resort to that.
  11. Thank you I really appreciate your help.

Share This Page