• This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

[8wayRun.Com] XenHabla (IRC)

Status
Not open for further replies.

gldtn

Well-known member
No I think it has to be set in the listener/NavTabs.php.. something like
Code:
<?php

if (!XenForo Visitor::getUserId()
class EWRhabla_Listener_NavTabs
{
    public static function listen(array &$extraTabs, $selectedTabId)
    {

        $extraTabs['chat'] = array(
            'title' => new XenForo_Phrase('chat'),
            'href' => XenForo_Link::buildPublicLink('full:chat'),
            'position' => 'middle',
            'linksTemplate' => 'EWRhabla_Navtabs',
        );
    }
}
but I'm not certain how to use that if conditional for applying it to usergroups :/, anyone?
 
Hey, sorry I may have missed this point in the discussions here, but is there anyway to just allow administrators to use this? Had a poke around but cant seem to find anything :(
 

bubbl3

Active member

Mibbit is getting banned on many private networks due to abuse, lightirc needs the adobe auth daemon installed on the box the irc server runs in order to connect, the only irc applet that really works is pjirc, would you please consider to add it? Thanks
 
My settings are almost identical to yours. I use the local CDN though and mine works OK. Gregory is right - you need 2 or more users before it will show.
 

RobParker

Well-known member
Hmm this morning I'm receiving this on my index.php page:

An exception occurred: Unable to read response, or response is empty in /var/hsphere/local/home/www/mydomain.co.uk/library/Zend/Http/Client.php on line 993
  1. Zend_Http_Client->request() in EWRhabla/Model/Chat.php at line 95
  2. EWRhabla_Model_Chat->getClientTable() in EWRhabla/Model/Chat.php at line 24
  3. EWRhabla_Model_Chat->fetchGeekShed() in EWRhabla/Model/Chat.php at line 12
  4. EWRhabla_Model_Chat->fetchUsers() in EWRporta/Block/ChatUsers.php at line 16
  5. EWRporta_Block_ChatUsers->getModule() in EWRporta/Model/Modules.php at line 220
  6. EWRporta_Model_Modules->getModuleParams() in EWRporta/ViewPublic/Portal.php at line 46
  7. EWRporta_ViewPublic_Portal->renderHtml() in XenForo/ViewRenderer/Abstract.php at line 222
  8. XenForo_ViewRenderer_Abstract->renderViewObject() in XenForo/ViewRenderer/HtmlPublic.php at line 67
  9. XenForo_ViewRenderer_HtmlPublic->renderView() in XenForo/FrontController.php at line 533
  10. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 156
  11. XenForo_FrontController->run() in /var/hsphere/local/home/www/mydomain.co.uk/index.php at line 13
Anyone have any idea?
 

RobParker

Well-known member
My settings are almost identical to yours. I use the local CDN though and mine works OK. Gregory is right - you need 2 or more users before it will show.
Is the limit definitely 2? We had 3 in the channel and nothing.

However, I set the channel as #help and it works fine and shows all 100-odd users in there.
 

RobParker

Well-known member
Nevermind, figured it out.

One of our ops had set the channel to +S and my IRC client wasn't showing that it had been set.

Thanks for everyone's help :)
 
I love this app. Is there anyway to make the sound work on every message received?

I'm unable to get the User Chat to show in the portal too and i have no idear why.
 

Lucas

Well-known member
Excellent addon!

Would it be possible to create a script that shows the number of online users on the same tab where it says "Chat" such as displaying "Chat (2)" and so forth?
 
Status
Not open for further replies.
Top