1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 405 Not Allowed

Discussion in 'Troubleshooting and Problems' started by butlerway, Sep 8, 2016.

  1. butlerway

    butlerway New Member

    I just converted from vBulletin to Xenforo. In my ACP I see this link: "There are manual rebuild processes that have been stopped before completion. Click here to complete them." This appears to be a mass email I tried to send out saying that the forums are back up and running. When I sent out the email, and whenever I click on the link, there are about 200 or so emails that go out before receiving this error:

    405 Not Allowed


    I really don't care too much about the emails continuing to go out (it's an old update now), but it appears this process not being completed is blocking me from finishing an install on some add ons I'd like to put in. Is there any way to fix this?
  2. Mike

    Mike XenForo Developer Staff Member

    To fix the 405, you likely need to contact your host. This is potentially something that will come up in other circumstances so that's worth doing. These sort of processes require a number of browser refreshes. This may be triggering an aggressive anti-DoS tool they're running. If it's an option, admin.php and deferred.php should be whitelisted.

    The alternative is to remove the email sending task, but I'm not sure if that's what you want. You should be able to cancel the job with the button when it is running, though you can also remove it from the database directly. If that's what you'd prefer, let me know.
  3. butlerway

    butlerway New Member

    Sounds like I do need to get this fixed and will definitely contact my host and try to get a more permanent fix. In the meantime I would like to go ahead and remove the email task so I can continue with some of the other tasks. There is no button that pops up while the job is running. It simply says "Processing..." for 10 seconds or so before going to the 405 error.
  4. Mike

    Mike XenForo Developer Staff Member

    You'll need to use something like phpMyAdmin and look in the xf_deferred table. There should be an entry with a "UserEmail" value (in
    execute_class). You need to delete that row.

Share This Page