1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 404 Error

Discussion in 'Troubleshooting and Problems' started by eekelmo, May 9, 2013.

  1. eekelmo

    eekelmo Member

    Hi there,

    I just installed xenForo, and its working great, although when I type "web.eekcraft.com", I get this error:
    You don't have permission to access / on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    I have tried changing the URL of my homepage to fix this (As I have heard that this happens because of a missing page/file), although, nothing came out of that. Is there a way to redirect my domain so "web.eekcraft.com", redirects to http://web.eekcraft.com/forums/index.php?portal/

    Thanks for your time :)
     
  2. 14DH01

    14DH01 Active Member

    try the .htaccess file in the root of your site
    www/.htaccess

    Code:
    Options +FollowSymLinks
    RewriteEngine On
     
    RewriteCond %{HTTP_HOST} !^www.yoursite.com$ [NC]
    RewriteRule ^ http://www.yoursite.com/forums? [R=301]
     
    
     
  3. 14DH01

    14DH01 Active Member

  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    To answer the original issue, it appears as if you've somehow changed the permissions on your file. Make sure files are able to be read and executed, which is chmod 0644.
     
  5. eekelmo

    eekelmo Member

    @Kibg kovifer which file would that be?
     
  6. Jeremy

    Jeremy XenForo Moderator Staff Member

    Specifically, index.php or the folder you uploaded XF to. Check both.
     
  7. eekelmo

    eekelmo Member

    No dice :(
     
  8. CyclingTribe

    CyclingTribe Well-Known Member

    Do you have any files in your root directory?

    If you don't have an index.html or index.php you'll usually see this error. (y)
     
    eekelmo and 14DH01 like this.
  9. eekelmo

    eekelmo Member

    Fixed :D
    Thank you so much, I had my xenForo installed in a sub directory, so I moved it into my web root and I no longer see this error! (y)
     
    CyclingTribe likes this.

Share This Page