• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 403 forbidden error with webdav

gldtn

Well-known member
#1
What ended up being the problem here? I just recently setup my Webdav connection, but when I try to save I get a "403 Forbidden: Access is denied."

Thanks!
 
R

ragtek

Guest
#2
What ended up being the problem here? I just recently setup my Webdav connection, but when I try to save I get a "403 Forbidden: Access is denied."

Thanks!
for webdav access you need to enable the debug mode
maybe this is the problem^^
 

gldtn

Well-known member
#4
Furthermore I'm using Transmit to connect and SublimeText2, it's seems like it deletes the template and tries to upload once I hit save and than I gives me the forbidden error. For me to see the template in Transmit again, I need to go in the admin control panel and save the template. Has anyone used these two programs with Xenforo Webdav function that can shine a light?

Thanks!
 

Jake Bunce

XenForo moderator
Staff member
#5
In your .htaccess file, try uncommenting this line by removing the hash:

Code:
	#	This line may be needed to enable WebDAV editing with PHP as a CGI.
	#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
 

gldtn

Well-known member
#6
Jake; no luck here

.htaccess from my xenforo dir, I also tried adding to my main dir .htaccess
Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>
 
<IfModule mod_rewrite.c>
    RewriteEngine On
 
    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    RewriteBase /comunidade
 
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data|js|styles|install) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
 
</IfModule>
 
# Mod_security can interfere with uploading of content such as attachments. If you
# cannot attach files, remove the "#" from the lines below.
<IfModule mod_security.c>
  SecFilterEngine Off
  SecFilterScanPOST Off
</IfModule>
 
#    This line may be needed to enable WebDAV editing with PHP as a CGI.
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
 

Jake Bunce

XenForo moderator
Staff member
#7
Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>
 
<IfModule mod_rewrite.c>
    RewriteEngine On
 
    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    RewriteBase /comunidade
 
    MOVE IT HERE

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data|js|styles|install) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
 
</IfModule>
 
# Mod_security can interfere with uploading of content such as attachments. If you
# cannot attach files, remove the "#" from the lines below.
<IfModule mod_security.c>
  SecFilterEngine Off
  SecFilterScanPOST Off
</IfModule>
 
#    This line may be needed to enable WebDAV editing with PHP as a CGI.
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
 

gldtn

Well-known member
#8
That didn't work either :/, must be something else blocking it. As I can get into my local server just fine :/. I'm almost done configuring my new server and I'll try it again.

Also, here on my local server when I save it, it seems to mess up my whole style. I'll give it another try and post here details as to exactly what's happening.

Thanks Jake!
 
R

ragtek

Guest
#9
what's messing exactly?

I'm also having several problems with webdav (e.g. deleteting randomly my templates instead of saving them,several times the template was saved, but as another template)

Never found out, why it happened, just stopped using webdav:D
 

gldtn

Well-known member
#10
It messed up several templates when I tried with Transmit and SublimeText 2, which I had to rebuild my style by uploading the .xml file to make it work again.

For example this in one of my templates:

Code:
<xen:include template="xfs_breadcrumb.css" />

Turned into this:
Code:
<link rel="xenforo_template" type="text/html" href="xfs_breadcrumb.css.html" />
While in Forklift2 or Cyberduck and SublimeText 2, when I open in in Sublime I see this:
Code:
<link rel="xenforo_template" type="text/html" href="xfs_breadcrumb.css.html" />
But, when saved and I open my template through the admin control panel it's saves correctly into this:
Code:
<xen:include template="xfs_breadcrumb.css" />
Not sure if that's how webdav is suppose to behave, but it seems the problem is in the way some ftp clients handle it. Probably some of them may need some in depth configuration? I do know that some people had reported working under Webdav in transmit with no problems.
 

gldtn

Well-known member
#11
I just found this article on the internet for all of those looking into Webdav: http://communities.rightnow.com/files/ccab0133c2/The_state_of_WebDAV_clients.pdf

They claim several problems with dreamweaver, but since kier uses it, Xenforo might be more compatible to it or debugging it might be quicker ;)

Here is another user having problems with transmit: http://xenforo.com/community/threads/webdav-editing-issue.26414/#post-321124

To me it seems like something that is not ready for prime time yet :p, so use it at your own risk!