1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

403/404 Error after upgrade to Beta2 and move to /xenforo folder

Discussion in 'Troubleshooting and Problems' started by jadmperry, Oct 31, 2010.

  1. jadmperry

    jadmperry Well-Known Member

    Sorry for this probably dumb question...

    I had installed beta1 and everything was working at mydomain.com .

    I wanted to explore various options with a portal page or Wordpress bridge, so before upgrading, I moved everything to mydomain.com/xenforo . I then upgraded to beta2, ran the script, and had a successful installation. I went to Admincp, updated my board URL to mydomain.com/xenforo .

    When I load the mydomain.com, I get a 403 error, and it also says "Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.."

    I know I am missing something simple, but haven't a clue what it might be. Change something in one of the files? Update DNS record? Something even more obvious?

    I appreciate the help, in advance!
     
  2. jadmperry

    jadmperry Well-Known Member

    Okay, update....sorry for the confusion...

    If I go to mydomain.com/Xenforo, my page is live....I am not sure that I will want this permanently, but I am guessing I have to use HTACCES to get mydomain.com to load mydomain.com/xenforo . Anyone know the easy way to do this or a link to the page where I am sure this has been covered (I just looked, but didn't find it, I am going to continue looking now....). Again, thanks!
     
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I would upload an index.php file to the web root that redirects to the new URL. Use the attached file. Edit the code to specify the new URL:

    Code:
    <?php
    
    header("Location: http://www.mydomain.com/xenforo/index.php");
    
    ?>
    
     

    Attached Files:

    jadmperry likes this.
  4. Blandt

    Blandt Well-Known Member

    Or make your document root at :your/previous/document/root/xenforo
     
    jadmperry likes this.
  5. jadmperry

    jadmperry Well-Known Member

    @Blandt,
    Can you explain further? Is this a setting, or do you mean place the index.php file in the path you mentioned?

    @Jake Bunce and @Blandt,

    Any relative difference between the approaches? I mean in terms of performance or other issues?

    Thanks to both of you for the quick reply!!
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I think Blandt is advising you to adjust your server configuration to change the web root. That would actually remove the /xenforo part of the URL which I don't think is what you want since that basically undoes the move to a subdirectory in terms of the URL.

    The index.php file I uploaded is a quick and easy fix. You just upload the file via FTP and that's it. It will redirect all forum pages on mydomain.com to mydomain.com/xenforo.
     
    jadmperry and Blandt like this.
  7. Blandt

    Blandt Well-Known Member

    at your server configuration (I'm not sure what you are using, Cpanel? ) look for Document root and point it to where you moved xenforo (you have mentioned that you moved it to ..../xenforo. so it should look something like : /home/users/myname/public_html/yoursite.com/xenforo
    When you are ready to install WP then move the document root back to your current document root.

    OR

    use Jake's solution by making a file name it index.php and put the code Jake provided, it will redirect all requests to the right folder
     
    jadmperry likes this.
  8. jadmperry

    jadmperry Well-Known Member

    Ah, okay....thanks, I knew it was something simple (yet beyond my recall/grasp).

    Thanks, I will try to fix based on the suggestions. You ever get in my neighborhood, I owe you a beer or three!

    I really appreciate the help!
     
    Blandt likes this.
  9. jadmperry

    jadmperry Well-Known Member

    Again, thanks, guys...I used the index.php method suggested by Jake Bunce. A quick pointer for anyone else who is facing the same, it is necessary to use correct capitalization (i.e., I tried and failed using /xenforo as the path, when I had specified /Xenforo as the folder in my root. Nothing that Jake would have known, as I didn't specify that in my OP; it was my fault for not being accurate in my description).

    Though I didn't use Blandt's method, I am glad he posted as it confirmed what I expected, that there was a way to do this in my host control panel.

    Goes without saying, I am learning....my only previous experience was with vB, so the parts that I am learning here, though limited, is helping round out my knowledge. Also, it is proof that this stuff is not that hard to do, if you spend some time to learn and are interested in doing this stuff yourself. I count myself as a novice, so, if I can do it (meaning, making your Xenforo board work), then most folks should be able to, too. Don't be afraid to try this forum software, as the issues are not that complicated.

    Again, thanks to both of you for the helping hand.
     
    djdrey likes this.

Share This Page