1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2nd page on thread is blank due to this error

Discussion in 'XenForo Questions and Support' started by surfsup, Feb 4, 2013.

  1. surfsup

    surfsup Well-Known Member

    visit this thread and click #2 you will see it comes up blank, not sure why? : http://www.truckmountforums.com/threads/well-here-i-go-again-blown-head-gasket.38755

    Code:
    ErrorException: array_key_exists() [<a href='function.array-key-exists'>function.array-key-exists</a>]: The second argument should be either an array or an object - library/XenAdShare/ControllerPublic/Thread.php:23
    Generated By: Unknown Account, A moment ago
    Stack Trace
     
    #0 [internal function]: XenForo_Application::handlePhpError('params', NULL)
    #1 /var/www/vhosts/truckmountforums.com/httpdocs/library/XenAdShare/ControllerPublic/Thread.php(23): array_key_exists()
    #2 /var/www/vhosts/truckmountforums.com/httpdocs/library/EWRmedio/ControllerPublic/Thread.php(7): XenAdShare_ControllerPublic_Thread->actionIndex()
    #3 /var/www/vhosts/truckmountforums.com/httpdocs/library/XenForo/FrontController.php(310): EWRmedio_ControllerPublic_Thread->actionIndex(Object(XenForo_RouteMatch))
    #4 /var/www/vhosts/truckmountforums.com/httpdocs/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch()
    #5 /var/www/vhosts/truckmountforums.com/httpdocs/index.php(13): XenForo_FrontController->run()
    #6 {main}
     
    Request State
     
    array(3) {
      ["url"] => string(85) "http://www.truckmountforums.com/threads/well-here-i-go-again-blown-head-gasket.38755/"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(0) {
      }
    }
    
     
  2. Brandon Sheley

    Brandon Sheley Well-Known Member

    wrong thread??

    http://www.truckmountforums.com/threads/well-here-i-go-again-blown-head-gasket.38636/

    see the thread id numbers aren't the same?

    This is the error from the 2nd page, I assume this is what you're talking about.
    Does it work with mods disabled, have you updated your cache lately?
    Try disabling the xenshare mod and/or the media one you've added
     
  3. surfsup

    surfsup Well-Known Member

    wow how in the world did that happen i wonder....
     
  4. Brandon Sheley

    Brandon Sheley Well-Known Member

    The thread id part?
    not sure, this is the section I found the thread is
    ask-our-repairmen.12
    is that were you expect it to be?
     
  5. surfsup

    surfsup Well-Known Member

    yes i moved it after i even got that error, both are public forums tho...

    I just updated my cache and still the same about the 2nd page - so strange....all other forums are fine when visiting any of the extra pages...
     
  6. Brandon Sheley

    Brandon Sheley Well-Known Member

    Moving it wouldn't have changed the thread ID though?..

    Either way, it seems you have a few errors (threads) on xf and I'm willing to bet they are all centered around a plugin or two.
    If it were me, I'd disable all the plugins, check the pages you're getting your errors on and make sure they are displaying as they should. Then turn one plugin on at a time, check your pages, and continue until it breaks.. The remove or see why that plugin is causing errors.
     
  7. surfsup

    surfsup Well-Known Member

    Found the problem, it was Chris's mod :/ something i highly need to argh: http://xenforo.com/community/resources/control-nofollow-urls.1389/

    1. All other threads that reached past 1 page works fine so I wonder if it's for newly pages thats created then when it hits 2nd page they go blank?

    So strange...maybe chris can chime in...
     
  8. Brandon Sheley

    Brandon Sheley Well-Known Member

    He's very active, I'd post in that thread explaining what you've found out and I'm sure he'll help out. :)

    glad you at least got this issue sorted
     
    surfsup likes this.
  9. Chris D

    Chris D XenForo Developer Staff Member

    None of this makes sense so far.

    I have spotted an improvement I could make to the code. So let's try that.

    That being said, I severely doubt my add-on is the only cause of this. There's nothing that would cause my add-on to not return a response and judging by your other threads here that aren't even related to threads (therefore not possible to be caused by my add-on) I think there might be other issues that need to be resolved.

    Here's a quick fix. Let me know if it makes any difference:
     

    Attached Files:

    surfsup likes this.
  10. surfsup

    surfsup Well-Known Member

    Yes this was the error (i left the other thread so we dont over take his sale lol) - anyways, yea i tried installing the new mod and same thing happens. Whats Strange is that it only happens to a few threads and some not. But after enabling the mod less than an hour I received many pms/emails saying ppl cant visit the 2nd+ pages. Ive tested the ones that they show me and it pulls up a blank screen but in tapatalk i can view the 2nd+ pages and on.
     
  11. Chris D

    Chris D XenForo Developer Staff Member

    Going back to this.

    The error doesn't mention my mod... neither does it use the array_key_exists function which is what threw the error in the first place.

    Specifically, XenAdShare is mentioned.

    Conflicts are obviously two way streets.

    Does that thread work if XenAdShare is disabled (with my add-on enabled)?
     

Share This Page