1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1.4B3 Virgin Install Can't login - cookies not accepted

Discussion in 'Installation, Upgrade, and Import Support' started by Erik P., Aug 21, 2014.

  1. Erik P.

    Erik P. Member

    I just did a virgin install of beta 3 but when I try to login to the board or the admin as the admin account I created on install I'm told I can't login until I have accepted cookies:

    Cookies are required to log in to this site. You will not be able to log in until they are accepted.

    There is no place to accept cookies I can find.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Is your browser configured to accept cookies?
     
  3. Erik P.

    Erik P. Member

    Yes.

    I just tried it again with the same result. I'll try it again on a more generic host VM config like linode and report back. Is there some 'do not try at home' workaround to disable the cookie check so I can get past the login?
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Can you PM me the link to the site and a log in so I can test?

    I have literally done hundreds of installs and never encountered that problem.
     
    Erik P. likes this.
  5. Erik P.

    Erik P. Member

    I can't give you a login to the one I just did because it's on a private network but I am trying again with a generic ubuntu linode host that will be publicly accessible. If I encounter the problem there too I'll PM you the details. Either way I will update with results.
     
  6. Erik P.

    Erik P. Member

    Ok, I found the issue and it's not a bug. php.ini parameter variables_order needs to include "C" or $_COOKIE is empty. It is disabled by default on my system for a number of internal reasons. It might be something worth adding to install config checks but like you say @Brogan, it's pretty rare to have this configuration out in the wild.
     
    Brogan likes this.
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Thanks for the update.
    Useful information for the future, if someone else posts about it.
     

Share This Page