1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 1.2.5 updrage file health check error?

Discussion in 'Installation, Upgrade, and Import Support' started by myco-tek.org, Feb 20, 2014.

  1. myco-tek.org

    myco-tek.org Member

    I updraged to 1.2.5 and everything seems alright. I only had 1 template to merge and that was just one of the custom skins.

    Then I went to check file health and I keep getting some kind of permission error occurring when I try and run the check.


    Here is the error log info
    ---

    Error Info:

    ErrorException: file_get_contents(library/Sabre/Sabre/DAV/Directory.php): failed to open stream: Permission denied - library/XenForo/Helper/Hash.php:66
    Generated By: Admin, 16 minutes ago


    Stack Trace

    #0 [internal function]: XenForo_Application::handlePhpError(2, 'file_get_conten...', '/home/mycotek/p...', 66, Array)
    #1 /home/mycotek/public_html/library/XenForo/Helper/Hash.php(66): file_get_contents('library/Sabre/S...')
    #2 /home/mycotek/public_html/library/XenForo/ControllerAdmin/Tools.php(254): XenForo_Helper_Hash::compareHashes(Array)
    #3 /home/mycotek/public_html/library/XenForo/FrontController.php(347): XenForo_ControllerAdmin_Tools->actionFileCheck()
    #4 /home/mycotek/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #5 /home/mycotek/public_html/admin.php(13): XenForo_FrontController->run()
    #6 {main}

    Request State

    array(3) {
    ["url"] => string(46) "
    admin login url"
    [
    "_GET"] => array(1) {
    ["tools/file-check"] => string(0) ""
    }
    ["_POST"] => array(1) {
    ["_xfToken"] => string(8) "********"
    }

    }

    -----

    This is a pic of the error I get when I try and check the file health.... ANy Ideas how to solve this? I am assuming I will have to just run the upgrade again but wanted to check in here and see what you guys had to say.... Thanks in advance!
    error pic.png
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    That errors indicates a file ownership/permission issue.

    You may need to check and correct it.
     
  3. myco-tek.org

    myco-tek.org Member

    How would I go about dong that? Is this something the webhost would have to change on my server? I do have multiple urls and redirects from a migration but it didn't mess with the last upgrade..
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Use your FTP application and check the permissions for library/Sabre/Sabre/DAV/Directory.php

    Ensure they are the same as the other files in the directory.
     
  5. myco-tek.org

    myco-tek.org Member

    The permission was set to 0000 which was not correct. All the other files were set to 0644 or 0755. I tried changing it to both but the same error still occurred with those permission settings too.....

    I also tried reuploading the DAV directory.php file but that didn't work either..
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Check ownership too.
    As the permissions were wrong, that is also likely wrong.
     
  7. myco-tek.org

    myco-tek.org Member

    I'm not really too sure how to do that??? I will try and reinstall the upgrade and see if that works and check back after that.
     
  8. myco-tek.org

    myco-tek.org Member

    Alright! Problem Solved! Thanks Brogan! highfive.gif
    Seems like you walk me through everything I can't figure out around here, lol.

    I went back through and checked the files and the ownership was correct on all of them. I then looked at the error log again and found that there was a 2nd file that didn't have the correct permissions assigned. I went in and fixed it and the following pic shows the result.

    Needless to say I am a happy camper now,. :)

    Untitled.png
     

Share This Page