• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

ZendFramework version dependencies?

Mike Tougeron

Well-known member
#1
I'm trying to integrate XenForo within another app that I have that also uses ZendFramework. What version of ZendFramework is required/compatible for XenForo? My main app is currently using 1.10.3

Thanks,
Mike
 

Jeremy P

Well-known member
#2
Zend/Version.php >> 1.11.1 currently. It'll probably be updated in a future release?
Also probably worth mentioning that while XenForo makes use of certain components it isn't strictly written on the framework.
 

Jeremy P

Well-known member
#4
Well, likely just the version used for release (and the current version at the time it was updated). Beta 1 ran 1.10.7. Maybe not strictly required but I'd expect the newer version of the framework to be more stable, of course.

I'm not sure if there's something keeping them from updating to the latest or if it just hasn't been a priority, though I do know one file of the framework was modified from the release version.

In my experience Zend doesn't break too much backward-compatibility wise, so maybe have your app run 1.11.1? Or from the XenForo distribution of the library?