1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Zend_Http_Client_Adapter_Exception: Read timed out after 10 seconds - library/Zend/Http/Client/Adapt

Discussion in 'Installation, Upgrade, and Import Support' started by Hornstar, May 2, 2014.

  1. Hornstar

    Hornstar Well-Known Member

    Since migrating to xenforo this week, I have noticed quite a few of these errors in my server log happening through out.

    Code:
    Server Error Log
    Error Info
    Zend_Http_Client_Adapter_Exception: Read timed out after 10 seconds - library/Zend/Http/Client/Adapter/Socket.php:512
    Generated By: Unknown Account, Today at 4:29 PM
    Stack Trace
    #0 /home/***/public_html/forums/library/Zend/Http/Client/Adapter/Socket.php(330): Zend_Http_Client_Adapter_Socket->_checkSocketReadTimeout()
    #1 /home/***/public_html/forums/library/Zend/Http/Client.php(989): Zend_Http_Client_Adapter_Socket->read()
    #2 /home/***/public_html/forums/library/Zend/Service/ReCaptcha.php(487): Zend_Http_Client->request('POST')
    #3 /home/***/public_html/forums/library/Zend/Service/ReCaptcha.php(502): Zend_Service_ReCaptcha->_post('03AHJ_VutzGME8R...', '????????')
    #4 /home/***/public_html/forums/library/XenForo/Captcha/ReCaptcha.php(53): Zend_Service_ReCaptcha->verify('03AHJ_VutzGME8R...', '????????')
    #5 /home/***/public_html/forums/library/XenForo/Captcha/Abstract.php(129): XenForo_Captcha_ReCaptcha->isValid(Array)
    #6 /home/***/public_html/forums/library/XenForo/ControllerPublic/Register.php(200): XenForo_Captcha_Abstract::validateDefault(Object(XenForo_Input))
    #7 /home/***/public_html/forums/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Register->actionRegister()
    #8 /home/***/public_html/forums/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #9 /home/***/public_html/forums/index.php(13): XenForo_FrontController->run()
    #10 {main}
    Request State
    array(3) {
    ["url"] => string(51) "http://www.***.net/forums/register/register"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(15) {
    ["username"] => string(5) "sQaFq"
    ["email"] => string(0) ""
    ["password"] => string(8) "********"
    ["password_confirm"] => string(8) "********"
    ["dob_month"] => string(1) "8"
    ["dob_day"] => string(2) "11"
    ["dob_year"] => string(4) "1982"
    ["gender"] => string(4) "male"
    ["timezone"] => string(17) "Pacific/Tongatapu"
    ["recaptcha_response_field"] => string(8) ""
    ["recaptcha_challenge_field"] => string(228) "03AHJ_VutzGME8R3J3bzloAajYHT1X0xo82fIRTYL47gAN0nloPxwvkhONqNv74JYnSzaGiJ6AAfpU3VwzJ4GcBUaAiO_zlsOPk83ftflsopBtudXHH79OtYOp6e16uwc9NFplM0T0xcWQTl2H8tbuzW8fMQBWCiZG1vJ_HnwcElmBBalBFkzH7qE_G-LUvqRFRxij-VhpVlLLe9nygPYcCJSH-1UUSwfY2g"
    ["agree"] => string(1) "1"
    ["submit"] => string(7) "Sign up"
    ["_xfToken"] => string(8) "********"
    ["reg_key"] => string(32) "153dd5abf6ae71c88b53a91d2af7ec3b"
    }
    }
    
    Any ideas why and what needs to be done to fix this?
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Looks like a temporary interruption in service from Recaptcha. Ignore it. Or don't use Recaptcha:

    Admin CP -> Home -> Options -> User Registration

    Screen shot 2014-05-02 at 12.48.30 AM.png
     

Share This Page