1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Zend Errors

Discussion in 'Troubleshooting and Problems' started by Edrondol, Nov 7, 2014.

  1. Edrondol

    Edrondol Well-Known Member

    I'm currently unable to upgrade addons or do much of anything in the AdminCP. Everything is running fine, but I'm static.

    The error:

    Server Error
    Mysqli prepare error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '? = ? WHERE user_id = ?' at line 2

    1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    4. Zend_Db_Adapter_Abstract->query() in Nobita/PostStaff/XenForo/DataWriter/User.php at line 50
    5. Nobita\PostStaff\XenForo\DataWriter\User->_postDelete() in Bookmarks/DataWriter/User.php at line 15
    6. Bookmarks_DataWriter_User->_postDelete() in XFSoccer/DataWriter/User.php at line 42
    7. XFSoccer_DataWriter_User->_postDelete() in XenForo/DataWriter.php at line 1779
    8. XenForo_DataWriter->delete() in XenForo/Deferred/UserAction.php at line 68
    9. XenForo_Deferred_UserAction->execute() in XenForo/Model/Deferred.php at line 256
    10. XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 390
    11. XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 335
    12. XenForo_Model_Deferred->run() in XenForo/ControllerAdmin/Tools.php at line 159
    13. XenForo_ControllerAdmin_Tools->actionRunDeferred() in XenForo/FrontController.php at line 347
    14. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    15. XenForo_FrontController->run() in /home/xxxxxx/public_html/xenforo/admin.php at line 13
    I have already run the master data rebuild and got no errors. I contacted the host based on THIS THREAD but he says he's made no changes. I totally get that this might be because of addons but at this point I can't even troubleshoot since I can't do anything with them and it's been a while since I added any new ones.

    Any help is appreciated.
  2. Edrondol

    Edrondol Well-Known Member

    Never mind. I figured it out. It was the Nobita Post as Staff addon messing stuff up. Bad Nobita! Bad!
    Claudio and Daniel Hood like this.

Share This Page