1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Yep, another animated avatar thread

Discussion in 'XenForo Questions and Support' started by Epitaffio, Mar 23, 2013.

  1. Epitaffio

    Epitaffio Member

    Hi all,

    in our ubuntu vps (XenForo 1.1.3) i've installed imagick (apt-get install php5-imagick) and imagemagick (apt-get install imagemagick), restarted apache2 (and also the vps), and selected imagick in the acp, but can't still see the animated avatar on the threads list or in posts.
    In phpinfo imagick is enabled.

    Also in the data/avatars, the gif are converted in jpg.

    What i should do or check now?
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    It's not retroactive. Did you try uploading a new animated avatar after setting up imagemagick?
     
  3. Epitaffio

    Epitaffio Member

    Yes, the avatars are still resized as jpg : (
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  5. Epitaffio

    Epitaffio Member

    Here it is my imagick from phpinfo, it should be the latest version because i've installed it yesterday, idem for imagemagick


    img1.png
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Epitaffio likes this.
  7. Epitaffio

    Epitaffio Member

    Hum, for testing purpose i'm using this:
    http://rumorsontheinternets.files.wordpress.com/2011/03/indianajonesgif.gif (ftw indie!)

    I have installed the latest version and now work like a charm (i can't understand why in the ftp the avatar is still in jpg o_O), btw here it is what i've done in ubuntu (i think it will do the trick in any other debian based)

    Code:
    sudo apt-get install make
    sudo apt-get install php5-pear
    sudo apt-get install php5-dev (i'm not quite sure it's needed)
    sudo apt-get install libmagickwand-dev libmagickcore-dev (or the pecl will stuck during the make)
    sudo pecl install imagick-3.1.0RC2 (only imagick won't work, and that it's the actual latest version)
    sudo nano /etc/php5/apache2/php.ini (or gedit or whatever you use)
    [INDENT=1]add the "extension=imagick.so" in the [extension] section[/INDENT]
    sudo /etc/init.d/apache2 restart (or nginx or you prefered webserver)
    
    now reupload the avatar.


    Hope this will help someone, and thank a lot Jake for pointing me out the latest pecl version!
     
    Jake Bunce likes this.

Share This Page