XWiki

XWiki [Paid] 1.1.0

No permission to buy ($279.95)

jiewaqpe

Member
If I pays once and decides not to pay next year. Can I still use this Add-On without updates or this will stop working?
 

gforce

Active member
If I pays once and decides not to pay next year. Can I still use this Add-On without updates or this will stop working?

It will work, but it's when Xenforo does a major upgrade; you'll likely have to pay again. They do some amazing work.
 

jiewaqpe

Member
It will work, but it's when Xenforo does a major upgrade; you'll likely have to pay again. They do some amazing work.
Once installed I don't update Xenforo. Will I have to pay again for this Add-On next year then if I don't update Xenforo or this Add-On? Does it supports php 7?
 

gforce

Active member
After reading all this, is it safe to use this wiki on a live forum?

You'll be ok to test it. It would be good if you could test it because it will provide them more feedback. I would only recommend for you to test this by conducting a full backup first. If this brings down your site, your admin panel will still work. You will need to delete the the wiki from xlink and you'll be back in business. I would not add this if your site is just running the site just bare metal without CPanel/PLESK.
 

gforce

Active member
Once installed I don't update Xenforo. Will I have to pay again for this Add-On next year then if I don't update Xenforo or this Add-On? Does it supports php 7?

Yes utilizes PHP7 including 7.2. Ya they let you keep running it. It's when you require follow on updates.
 

Vekseid

Active member
Congratulations.

The XLink demos on your site feel extremely slow, however, and this appears to poison the rest of the demo - e.g. even the forums feel slow in comparison to your other demos.

Are there metrics available?
 

RobinHood

Well-known member
On the demo it seems that many of the edits are attributed to IP addresses instead of users. Is that because the edit was carried out by a non-registered user?

If so, can you set permissions so that only registered users can edit the wiki so IP addresses aren't exposed?
 

FrankPereiro

Active member
You'll be ok to test it. It would be good if you could test it because it will provide them more feedback. I would only recommend for you to test this by conducting a full backup first. If this brings down your site, your admin panel will still work. You will need to delete the the wiki from xlink and you'll be back in business. I would not add this if your site is just running the site just bare metal without CPanel/PLESK.

Thanks for your reply.

I'd better wait until it's more stable to buy it.

I really want to use this add-on instead of the one I'm using right now because I think it's too basic, and besides, I've always been a great fan of Mediawiki...
 

EgvAg

Member
I get this Error when installing: [TH] XWiki requires [TH] XLink.
In the documentation I can read: Your first step is to download the add-on from your customer area.

But I can´t find any XLink Download. Somebody an idea?
 

gforce

Active member
I get this Error when installing: [TH] XWiki requires [TH] XLink.
In the documentation I can read: Your first step is to download the add-on from your customer area.

But I can´t find any XLink Download. Somebody an idea?

xlink just shows up like any of them. you may need to post a ticket if you don't see it
 

gforce

Active member
at @ThemeHouse @Mike Creuzer whartever @Lukas W. did as a fix on my box works. so ya, he made it less intense and doesn't take the box out. the server is a dedicated server running a 1230v2 xeon processor with 16gb of ram; so was weird it went down in the past.

Anyone who is looking to buying this product; whenever the next patch is released it works. See it running at https://pgblitz.com/wiki
 
Last edited:

ThemeHouse

Well-known member
ThemeHouse updated XWiki with a new update entry:

XLink Version 1.0.3 released!

Changes:
  • Resolved an issue that would block access to the search result tabs of other platforms if XenForo did have no search results.
  • Resolved an issue that would show a wrong breadcrumb root level on various occassions.
  • Added the ability to import remote platform accounts into XenForo.
  • Resolved an issue that would prevent "show ads" to be correctly checked when opening a platform edit page.
  • Resolved various API cache errors.
  • Strip out various duplicated head...

Read the rest of this update entry...
 

ThemeHouse

Well-known member
ThemeHouse updated XWiki with a new update entry:

Version 1.0.1 released!

Changes:
  • Added search tabs to the search result page.
  • Resolved an issue that would prevent the MediaWiki header meta information from being injected.
  • Resolved an issue that would prevent XLink to make calls to the UserGroup API.
  • Resolved a number of issues related to user generation.
  • Resolved an issue that would prevent user group promotions to be added.
  • Resolved an issue that would prevent the printable version from being accessible.
  • Resolved an issue that...

Read the rest of this update entry...
 

Lukas W.

Well-known member
How is this working after the latest update? I'm interested in buying it :)
No open performance complaints afaik.

Could you guys reply to my ticket? Having some issues with installation.
We'll get back to you on Monday first thing. Have you checked out the documentation? A lot of the stuff of the XPress troubleshooting section can also be applied to XWiki in a slightly modified form.
 

darvil

Member
Thanks Lukas,

I'll try again but manually this time.

The error I got is

  • Error: Class 'ThemeHouse\Core\Http\HttpClient' not found src/addons/ThemeHouse/XLink/RemoteHandler/Traits/APICall.php:31
I am doing a fresh xenforo + fresh mediawiki install in order to eliminate obvious errors.


Darvil
 
Top