XPress - A theme and bridge for bringing WordPress into XenForo

XPress - A theme and bridge for bringing WordPress into XenForo 1.1.3 Patch Level 2

No permission to buy ($299.95)

diretur

Active member
I've made it working by myself:
Change \wp-content\plugins\wp-xpress-plugin\src\XPress.php:
PHP:
if (!class_exists('\XPress')) {

    if (!defined('XPRESS_COMPATIBLE_POST_TYPES')) {

        define('XPRESS_COMPATIBLE_POST_TYPES', ['post', 'addons']);

    }
change 'addons' with your custom posttype.
great, thanks!
 

markransome

Member
Hi,

After reading all the documentation and comments here I am still a little confused about what I actually want to know, and that is, are users able to post to Wordpress will then automatically show up in the forum? What I mean to say, does this theme/plugin give users the ability to post to WP from the front end?

Mark
 
Last edited:

Lukas W.

Formerly katsulynx
After reading all the documentation and comments here I am still a little confused about what I actually want to know, and that is, are users able to post to Wordpress will then automatically show up in the forum? What I mean to say, does this theme/plugin give users the ability to post to WP from the front end?
Depends on the way the theme/plugin realizes the ability to post from the frontend. There's no definitive answer to this question due to the way WordPress works.
 

Upgrayedd

New member
Any method that works to force a certain style when people are browsing outside of the forum itself? I thought the option to select default style for it was it but I just misread what it does.

I use both UI.X dark and light, but I also integrate with aMember and Wordpress. I really really don't have time to go through the dark mode to fix any CSS issues. Does anyone have a method to make it so any non-XF pages use the XF light style?
 

RoyalRumble

Active member
I'm almost giving up on this plugin...

All I wanted it for was the comments syncing. At $80 it barely works for me :-(

  • Avatars not working in WP
  • Comment sync barely works... comment 'test' (post 26) not syncing from XF to Wordpress.
Thread: https://www.emtbforums.com/community/threads/greyp-g6-bike-launched-live-streaming-internet-connected-smart-bike.4387/
Article: https://www.emtbforums.com/greyp-g6-bike-launched-live-streaming-internet-connected-emtb/

I tried to update the WP article to the XF thread... It made another thread in XF? Mismatched comments / threads from WP to XF here:

Thread: https://www.emtbforums.com/community/threads/yt-decoy-first-ride-review-a-brilliant-ebike-with-outstanding-performance.4646/
Article: https://www.emtbforums.com/yt-decoy-all-new-emtb/
These are my settings, dont think ive disabled anything?

Hello

Would you mind kindly advising how you resolved the avatar issue?

Coincidentally - I have the same wordpress theme as you and have the same issue. I paid for a professional install and confident its now down to any setting...

1568730336236.png

[Edit] Never mind, I just disabled avatars.
 
Last edited:

MattRock

Member
Hello,

I've done some searching here but haven't found a solution yet. I have 3 issues, and I'm wondering if anyone else has experienced these and might be able to provide a solution:

1) On the wordpress site, it appears that Alerts and Messages aren't painting into the drop-down. As illustrated below, they simply say "Loading...". This functionality does work properly on the Xenforo forum pages.

1568922633020.png

2) I can't seem to adjust the formatting of the Author block on wordpress articles. If I make changes in the Xpress area of the style, they aren't reflected on my Wordpress article pages. The formatting I get is just very basic:

1568922767146.png

3) Does anyone know how to customize the font of just wordpress articles? I prefer a Times New Roman font but can't find any location to set it as such.

Thanks for any help that may be provided!
 

Upgrayedd

New member
3) Does anyone know how to customize the font of just wordpress articles? I prefer a Times New Roman font but can't find any location to set it as such.
This works for me on your site:
Code:
.type-post p {
     font-family: "Times New Roman", Times, serif;
     font-size: 18px;           
}
1568930853116.png

Adjust the font size if you want more.


Same thing would work for the box at the bottom, just find the class for it. I'd do it right now but gotta get back to my stuff...but yeah right click and hit inspect element. Feel free to PM me if you need any help as we both seem to run similar sites.
 

Namoh

Member
I just purchased this addon but keep getting a lot of errors. Does anyone know how to solve this? The themehouse dev wont be able to answer till Monday.

Ive added api key password to test If that's the issue but it isn't.
 

Attachments

Sperber

Well-known member
I just purchased this addon but keep getting a lot of errors. Does anyone know how to solve this? The themehouse dev wont be able to answer till Monday.

Ive added api key password to test If that's the issue but it isn't.
Same error with me. Themehouse has already received a ticket almost 3 weeks ago for this. Unfortunal they are a bit busy the last weeks.
 

diretur

Active member
I just purchased this addon but keep getting a lot of errors. Does anyone know how to solve this? The themehouse dev wont be able to answer till Monday.

Ive added api key password to test If that's the issue but it isn't.
are you on cloudfare?
 

diretur

Active member
Haven´t set up an API key by now. Which API scopes have you enabled and which type of key have you used?
this is the reply to my ticket from TH:

I’ve troubleshooted the situation as far as I’ve could. It appears, that your WordPress instance is recognizing the ingoing call from XenForo as being made from the IP 162..., while having an outwards facing IP of 52.... The former appears to be from cloudflare, while the latter is from amazon (I’m assuming that is your server host).
I’ve implemented a password protected workaround for now. The password is stored in both your config files (XenForo and WordPress), but I recommend that you check out if it’s possible to prevent cloudflare from masking your own servers calls, otherwise XPress won’t be able to recognize them as its own (and somewhat rightfully so, as the cloudflare machine is indeed a different one than the server itself).
 

Sperber

Well-known member
this is the reply to my ticket from TH:

I’ve troubleshooted the situation as far as I’ve could. It appears, that your WordPress instance is recognizing the ingoing call from XenForo as being made from the IP 162..., while having an outwards facing IP of 52.... The former appears to be from cloudflare, while the latter is from amazon (I’m assuming that is your server host).
I’ve implemented a password protected workaround for now. The password is stored in both your config files (XenForo and WordPress), but I recommend that you check out if it’s possible to prevent cloudflare from masking your own servers calls, otherwise XPress won’t be able to recognize them as its own (and somewhat rightfully so, as the cloudflare machine is indeed a different one than the server itself).
Interesting. Since we also use https with STRICT enabled I hope that doesn´t add to the problem itself.. Hope they can release a bugfix version for that soon, since everything that has to synchronize with XLink/XPress results in the same error. Widgets, user registration, aso, aso.
 
Top