XPress - A theme and bridge for bringing WordPress into XenForo

XPress - A theme and bridge for bringing WordPress into XenForo 1.1.2

No permission to buy ($99.95)

ssj2_ssbm

Member
I plan on using this in a forum where we'd like to merge news that were posted in the WordPress blog in existing threads. I don't want a new thread to be created. Is that possible with this add-on?
 

Lukas W.

Formerly katsulynx
I plan on using this in a forum where we'd like to merge news that were posted in the WordPress blog in existing threads. I don't want a new thread to be created. Is that possible with this add-on?
No. You can link a thread to only one WordPress post at a time. Multiple WP posts pointing to the same XF thread is not possible.
 
Hey,

I'm just read around 25 pages in this thread and I shouldn't do that, because now I've 10 answers pro and 10 against for features I need for my project. Because I used XenWord before and plan a relaunch of my sites. I keep it simple, I am very experienced about how to create themes or designs for wordpress and xenforo, so no need to have a "optical bridge" and just want a clear answer :)

Can XPress provide me the following features:
  • Single Sign On between an own themed wordpress 5.x and xenforo 2.1
  • XenForo users can comment wordpress articles
  • Widgets between wordpress and xenforo in both ways (login, stats, posts(threads)/articles)
Some answers are saying it doesn't work without a special themed wordpress, some saying it does. I am not talking about design issues like jQuery etc. Thank you very much.
 
Last edited:

Kirby

Well-known member
Race Condition causing logged error

ThemeHouse\XLink\RemoteHandler\Traints\SimpleCache::setSimpleCache()

PHP:
if (File::abstractedPathExists($path)) {
    File::deleteFromAbstractedPath($path);
}

try {
    $fs->write($path, json_encode($data));
} catch (FileExistsException $e) {
    // File probably created in a concurrent request, ignore
} catch (\Exception $e) {
    \XF::logException(new \Exception('XLink could not write API cache. Please check your directory and file permissions.',
        null, $e));
}
If this is called concurrently, it can happen that the file is being deleted by process 2 while process 1 is still processing the write, eg. has written the file but not yet applied chmod() within FlySystem.

This creaates an Error, which normally the XenForo PHP Error Handler would convert to an exception so it can be catched & ignored in XF\LocalFsAdapter::setVisibility()

However, XLink does call the above code form within a template, in which case the Templater does change the error handler and an exception does get logged directly.

Code:
#0 [internal function]: XF\Template\Templater->handleTemplateError(2, 'chmod(): No suc...', '<path>...', 357, Array)
#1 src/vendor/league/flysystem/src/Adapter/Local.php(357): chmod('<path>...', 420)
#2 src/XF/LocalFsAdapter.php(71): League\Flysystem\Adapter\Local->setVisibility('xlink_api_cache...', 'public')
#3 src/vendor/league/flysystem/src/Adapter/Local.php(145): XF\LocalFsAdapter->setVisibility('xlink_api_cache...', 'public')
#4 src/vendor/league/flysystem/src/Filesystem.php(69): League\Flysystem\Adapter\Local->write('xlink_api_cache...', '[{"id":18,"link...', Object(League\Flysystem\Config))
#5 [internal function]: League\Flysystem\Filesystem->write('xlink_api_cache...', '[{"id":18,"link...', Object(League\Flysystem\Config))
#6 src/vendor/league/flysystem-eventable-filesystem/src/EventableFilesystem.php(431): call_user_func_array('parent::write', Array)
#7 src/vendor/league/flysystem-eventable-filesystem/src/EventableFilesystem.php(395): League\Flysystem\EventableFilesystem\EventableFilesystem->callFilesystemMethod('write', Array)
#8 src/vendor/league/flysystem-eventable-filesystem/src/EventableFilesystem.php(247): League\Flysystem\EventableFilesystem\EventableFilesystem->delegateMethodCall('write', Array)
#9 src/vendor/league/flysystem/src/MountManager.php(441): League\Flysystem\EventableFilesystem\EventableFilesystem->write('xlink_api_cache...', '[{"id":18,"link...', Array)
#10 src/addons/ThemeHouse/XLink/RemoteHandler/Traits/SimpleCache.php(93): League\Flysystem\MountManager->write('xlink_api_cache...', '[{"id":18,"link...')
#11 src/addons/ThemeHouse/XLink/RemoteHandler/Traits/APICall.php(83): ThemeHouse\XPress\RemoteHandler\Platform->setSimpleCache('999e7a8b343f114...', Array)
#12 src/addons/ThemeHouse/XPress/RemoteHandler/Platform.php(207): ThemeHouse\XPress\RemoteHandler\Platform->callAPI('/wp/v2/categori...', Array)
#13 src/addons/ThemeHouse/XLink/Navigation/RemoteNavigation.php(139): ThemeHouse\XPress\RemoteHandler\Platform->getSubnavigation()
#14 <path>/code-cache/navigation_cache.php(309): ThemeHouse\XLink\Navigation\RemoteNavigation::displayPlatformExtended(6, 'thxlink_1')
#15 src/XF/Template/Templater.php(6628): XF\Pub\App->{closure}(Object(Fh\PageContext\XF\Template\Templater), 'forums', Array)
#16 src/XF/Pub/App.php(560): XF\Template\Templater->renderNavigationClosure(Object(Closure), 'forums', Array)
#17 src/XF/Pub/App.php(513): XF\Pub\App->getNavigation(Array, 'forums')
#18 src/XF/App.php(1988): XF\Pub\App->renderPageHtml('...', Array, Object(XF\Mvc\Reply\View), Object(XF\Mvc\Renderer\Html))
#19 src/XF/Mvc/Dispatcher.php(362): XF\App->renderPage('...', Object(XF\Mvc\Reply\View), Object(XF\Mvc\Renderer\Html))
#20 src/XF/Mvc/Dispatcher.php(53): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#21 src/XF/App.php(2177): XF\Mvc\Dispatcher->run()
#22 src/XF.php(390): XF\App->run()
#23 index.php(20): XF::runApp('XF\\Pub\\App')
#24 {main}
[/php]
 

ThemeHouse

Well-known member
ThemeHouse updated XPress - A theme and bridge for bringing WordPress into XenForo with a new update entry:

Version 1.1.2 released!

Changes:
  • Resolved a javascript error preventing native WP comments from being inserted dynamically after being posted.
  • Resolved an error preventing editing tags on threads linked to WP posts.
  • WP Post featured images are now used as Open Graph images for the linked XenForo thread too.
  • Added page criteria for WordPress categories (XPress theme only).
Read the rest of this update entry...
 
  • Resolved a javascript error preventing native WP comments from being inserted dynamically after being posted.
Please recheck. It still uses Xenforo Comments when WP Comments checked.
 

PASS

Active member
Just FYI for anyone running PHP-FPM. I was getting 500 Internal Server errors when trying to setup the 'platform' in Xlink via the XF CP. Then once I did get it set, I would get hundreds and hundreds of non stop errors in the XF log until I deleted the platform link.

It looks to be related to PHP-FPM so I turned it off, and the platform installed without issue. No errors at all. I have it off temporarily but PHP-FPM is important for me to have on.


Capture.PNG

Is this something that can be fixed in Xpress/Xlink?
 
Last edited:

Dalton Prock

Well-known member
  • Resolved a javascript error preventing native WP comments from being inserted dynamically after being posted.
Please recheck. It still uses Xenforo Comments when WP Comments checked.
Could you please send us the error that you are experiencing through ticket? So that we can assist you further with resolving this issue. You can do so by creating a ticket here.

Just FYI for anyone running PHP-FPM. I was getting 500 Internal Server errors when trying to setup the 'platform' in Xlink via the XF CP. Then once I did get it set, I would get hundreds and hundreds of non stop errors in the XF log until I deleted the platform link.

It looks to be related to PHP-FPM so I turned it off, and the platform installed without issue. No errors at all. I have it off temporarily but PHP-FPM is important for me to have on.


View attachment 205811

Is this something that can be fixed in Xpress/Xlink?
Please if you would create a ticket with us on our support portal so we can take a closer look at this issue and so one of our team members can help resolve it for you as well.
 

PASS

Active member
Please if you would create a ticket with us on our support portal so we can take a closer look at this issue and so one of our team members can help resolve it for you as well.
Hi Dalton,

Ticket was already created #14468. I was told I'd have to wait until the next release (no ETA on that) and providing a patch was not possible.
I had to disable this add-on so I could turn PHP-FPM back on. My server loads double with it off.
 

Kirby

Well-known member
Bug
XLink does not allow to select a forum for comments if it is not configured to be visible in the node list.

This does get worse if a forum is configured, afterwards made invisible and the platform settings saved again - in this case the previously configured working setting does get reset, eg. no forum will be selected after saving without any notice that this did happen.

This is caused by using
PHP:
$nodeRepo = $this->repository('XF:Node');
$nodeTree = $nodeRepo->createNodeTree($nodeRepo->getNodeList());
which does filter out nodes that are not visible in the node list.

You should probably use getFullNodeList() or maybe smth. like
PHP:
$nodeRepo = \XF::repository('XF:Node');

$choices = $nodeRepo->getNodeOptionsData(true, 'Forum', 'option');
$choices = array_map(function($v) {
    $v['label'] = \XF::escapeString($v['label']);
    return $v;
}, $choices);
 

Jens1986

Active member
Hi, anyone else getting error in Google Search Console? They say my front page (of XPress) is not mobile friendly because the text is too small and the clickable items are too close.
 
Top