[XFA] Like Or Reply To View Attachment - XF2

[XFA] Like Or Reply To View Attachment - XF2 [Paid] 1.2.0

No permission to buy (€10.00)

Fredxd

Well-known member
Nop only 2.2
I have change template modification in order to fix it in 2.2.
If needed i will can give you fix here, in order to fix file yourself for 2.1
 

spicer

Active member
Thx. Is ok. You don't must create.
I will run my forum a long time with XF2.1. XF2.2 is to new. (many errors ^^ )
 

Fredxd

Well-known member
I don't see anything about your issue on my dev forum
Can you explain more in which conditions you have this issue ?
Thanks
 
Hi
You can find template start by xfa_lrva_ and edit it

Regards
yes, i'm not good at coding
but i tried removing the img tag and replacing it with text it seems that the text is not working, no text is displayed, and nothing is left there

Thank you for your help, if you can give more detailed instructions it would be great
 

Fredxd

Well-known member
In xfa_lrva_macros template you can replace

Code:
<li class="attachment">
        <div class="attachment-icon attachment-icon--img">
            <a>
                <img src="{$xf.options.xfa_lrva_thumbnail_replacement_image}" />
            </a>
        </div>
    </li>

by

Code:
<li class="attachment">
        Your text here
    </li>

And it's should work ;)
 
In xfa_lrva_macros template you can replace

Code:
<li class="attachment">
        <div class="attachment-icon attachment-icon--img">
            <a>
                <img src="{$xf.options.xfa_lrva_thumbnail_replacement_image}" />
            </a>
        </div>
    </li>

by

Code:
<li class="attachment">
        Your text here
    </li>

And it's should work ;)
thank you very very much ^^
 

Dr-SpinXO

Member
Hello, when I try to download something in the attachment, I get this error message
Code:
ErrorException: [E_WARNING] Invalid argument supplied for foreach() in src/addons/XFA/LikeReplyViewAttachment/XF/Entity/Post.php at line 35
XF::handlePhpError() in src/addons/XFA/LikeReplyViewAttachment/XF/Entity/Post.php at line 35
XFA\LikeReplyViewAttachment\XF\Entity\Post->_hasLikePost() in src/addons/XFA/LikeReplyViewAttachment/XF/Entity/Attachment.php at line 66
XFA\LikeReplyViewAttachment\XF\Entity\Attachment->canViewLrva() in src/addons/XFA/LikeReplyViewAttachment/XF/Entity/Attachment.php at line 25
XFA\LikeReplyViewAttachment\XF\Entity\Attachment->canView() in src/XF/Pub/Controller/Attachment.php at line 31
XF\Pub\Controller\Attachment->actionIndex() in src/XF/Mvc/Dispatcher.php at line 352
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 259
XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 115
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 57
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2351
XF\App->run() in src/XF.php at line 517
XF::runApp() in index.php at line 20

How can I solve the problem and what is the reason?
 

Attachments

  • Screenshot 2022-03-14 202539.png
    Screenshot 2022-03-14 202539.png
    180.7 KB · Views: 3

Fredxd

Well-known member
Hello, when I try to download something in the attachment, I get this error message
Code:
ErrorException: [E_WARNING] Invalid argument supplied for foreach() in src/addons/XFA/LikeReplyViewAttachment/XF/Entity/Post.php at line 35
XF::handlePhpError() in src/addons/XFA/LikeReplyViewAttachment/XF/Entity/Post.php at line 35
XFA\LikeReplyViewAttachment\XF\Entity\Post->_hasLikePost() in src/addons/XFA/LikeReplyViewAttachment/XF/Entity/Attachment.php at line 66
XFA\LikeReplyViewAttachment\XF\Entity\Attachment->canViewLrva() in src/addons/XFA/LikeReplyViewAttachment/XF/Entity/Attachment.php at line 25
XFA\LikeReplyViewAttachment\XF\Entity\Attachment->canView() in src/XF/Pub/Controller/Attachment.php at line 31
XF\Pub\Controller\Attachment->actionIndex() in src/XF/Mvc/Dispatcher.php at line 352
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 259
XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 115
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 57
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2351
XF\App->run() in src/XF.php at line 517
XF::runApp() in index.php at line 20

How can I solve the problem and what is the reason?
Hi,
Please use our support forum for this.
Regards
 
Top