1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[XFA] Apple App Store BBCode 2.0.1

New Apple App Store BBCode for your forum.

  1. XFA

    XFA Well-Known Member

    THLove likes this.
  2. Axel B

    Axel B Well-Known Member

    Looks very interesting! Is it also possible to something similar with Google Play Store?
     
  3. MtoR

    MtoR Well-Known Member

    This is something we considered but we haven't yet done it.
     
    THLove likes this.
  4. Axel B

    Axel B Well-Known Member

    Ah ok :) Thanks for considering ;)
     
  5. THLove

    THLove Member

    Thanks you, great addon.. Awesome :D
     
  6. THLove

    THLove Member

    Server Error Logs :( .. @MtoR, you can help me?

    Code:
    ErrorException: Array to string conversion - library/XFA/AppleAppStoreBBCode/Callback.php:42
    
    #0 /domain.com/public_html/library/XFA/AppleAppStoreBBCode/Callback.php(42): XenForo_Application::handlePhpError(8, 'Array to string...', '/domain.com...', 42, Array)
    #1 [internal function]: XFA_AppleAppStoreBBCode_Callback::renderTagApple(Array, Array, Object(EWRporta2_BbCode_Formatter))
    #2 /domain.com/public_html/library/XenForo/BbCode/Formatter/Base.php(745): call_user_func(Array, Array, Array, Object(EWRporta2_BbCode_Formatter))
    #3 /domain.com/public_html/library/XenForo/BbCode/Formatter/Base.php(652): XenForo_BbCode_Formatter_Base->renderValidTag(Array, Array, Array)
    #4 /domain.com/public_html/library/XenForo/BbCode/Formatter/Base.php(565): XenForo_BbCode_Formatter_Base->renderTag(Array, Array, 0)
    #5 /domain.com/public_html/library/XenForo/BbCode/Formatter/Base.php(546): XenForo_BbCode_Formatter_Base->renderTreeElement(Array, Array, 0)
    #6 /domain.com/public_html/library/XenForo/BbCode/Formatter/Base.php(526): XenForo_BbCode_Formatter_Base->renderSubTree(Array, Array)
    #7 /domain.com/public_html/library/XenForo/BbCode/Parser.php(505): XenForo_BbCode_Formatter_Base->renderTree(Array, Array)
    #8 /domain.com/public_html/library/XenForo/ViewPublic/Forum/View.php(64): XenForo_BbCode_Parser->render('[APPLE]https://...', Array)
    #9 /domain.com/public_html/library/XenForo/ViewRenderer/Abstract.php(227): XenForo_ViewPublic_Forum_View->renderRss()
    #10 /domain.com/public_html/library/XenForo/ViewRenderer/Rss.php(31): XenForo_ViewRenderer_Abstract->renderViewObject('XenForo_ViewPub...', 'Rss', Array, 'forum_view')
    #11 /domain.com/public_html/library/XenForo/FrontController.php(605): XenForo_ViewRenderer_Rss->renderView('XenForo_ViewPub...', Array, 'forum_view', NULL)
    #12 /domain.com/public_html/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_Rss), Array)
    #13 /domain.com/public_html/index.php(13): XenForo_FrontController->run()
    #14 {main}
    
    array(3) {
      ["url"] => string(60) "domain.com/forums/test-forums.2/index.rss"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(0) {
      }
    }
     
  7. MtoR

    MtoR Well-Known Member

    Do you have the content of the corresponding post for me to reproduce ?
     
  8. THLove

    THLove Member

    After install addon XenPorta, it's show error on sever error logs.. I think your addon don't integration with XenPorta
     
  9. MtoR

    MtoR Well-Known Member

    Oh found out, one line 42, there is a double $ somewhere on the line.

    Replace it by a single $ it should fix the issue.
     
  10. XFA

    XFA Well-Known Member

    THLove likes this.
  11. THLove

    THLove Member

    @XFA yeah, new update working with my forum.. Thanks you
     
    MtoR likes this.

Share This Page