1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Xf doesnt showing the captcha to guest

Discussion in 'Troubleshooting and Problems' started by Gabriel Pinho, Sep 8, 2012.

  1. Gabriel Pinho

    Gabriel Pinho Member

    Hi,

    My contact form is working fine to registered members, but when a guest try to send a contact message, the system doesn't show the captcha:

    ScreenHunter_01 Sep. 08 12.34.jpg

    If the guest try to send filling all fields, whitout the captch field, the board returns a captcha's error.

    Anyone know how can i solve that? Or how can i take off the captcha just to the guest's contact form at /misc/contact?

    Thanks a lot. ;)
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Which captcha are you using? Recaptcha or Q&A?

    Admin CP -> Home -> Options -> User Registration -> Enable CAPTCHA for Guests

    Q&A requires you to setup your own questions if you haven't already.
     
  3. Gabriel Pinho

    Gabriel Pinho Member

    Yeah.. i know this option, but if i disable it, all board will work without a captcha protection. Have you any hook tip to disable it just to the guet contact form?
     
  4. Gabriel Pinho

    Gabriel Pinho Member

    Please help me. :unsure:
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Can you post the URL to your forum? I want to test this myself.

    Otherwise it could be a style or addon problem. You can troubleshoot that by testing the problem on the default style with no addons.
     
    Gabriel Pinho likes this.
  6. Gabriel Pinho

    Gabriel Pinho Member

    Sure..

    www.pfps.com.br

    I don't know when this problem started but at a short time ago everything was okay. Have you any way to just disable the captcha to guest in the contact form?

    Sorry for my English and thanks for your attention.
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  8. Russ

    Russ Well-Known Member

    KeyCaptcha doesn't work in overlays, disable the overlay in the link in the template: footer

    find:
    Code:
    <li><a href="{xen:link 'misc/contact'}" class="OverlayTrigger" data-overlayOptions="{&quot;fixed&quot;:false}">{xen:phrase contact_us}</a></li>
    
    Replace:
    Code:
    <li><a href="{xen:link 'misc/contact'}">{xen:phrase contact_us}</a></li>
    
     
    Jake Bunce likes this.
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Oh. I didn't test the overlay. I just opened a new window. Good call Russ.
     

Share This Page