XF 2.1 Problem With Xenforo Advanced Search Plug In Install

oneobgyn

Member
we are on a VPS
ElasticSearch has been installed and configured.
It has been tested and ElasticSearch is working.
But XenForo is having an issue enabling it.

The error is:
=================================
XFES\Elasticsearch\RequestException: Failed to parse mapping [_doc]: Root mapping definition has unsupported parameters: [xf : {_source={enabled=false}, properties={date={store=true, type=long}, resprefix={type=long}, hidden={type=boolean}, content_id={type=long}, resource={type=long}, prefix={type=long}, thread={type=long}, classifiedscat={type=long}, title={type=text}, message={type=text}, type={type=keyword}, node={type=long}, profile_user={type=long}, mediaalbum={type=long}, content_type={type=text}, discussion_id={store=true, type=long}, tag={type=long}, rescat={type=long}, listing={type=long}, user={store=true, type=long}, mediacat={type=long}, classifiedsprefix={type=long}}}] in src/addons/XFES/Elasticsearch/Api.php at line 387
XFES\Elasticsearch\Api->request() in src/addons/XFES/Elasticsearch/Api.php at line 287
XFES\Elasticsearch\Api->createIndex() in src/addons/XFES/Service/Optimizer.php at line 85
XFES\Service\Optimizer->optimize() in src/addons/XFES/Service/Configurer.php at line 67
XFES\Service\Configurer->initializeIndex() in src/addons/XFES/Admin/Controller/EnhancedSearch.php at line 129
XFES\Admin\Controller\EnhancedSearch->actionSetup() in src/XF/Mvc/Dispatcher.php at line 497
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 175
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 81
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 3861
XF\App->run() in src/XF.php at line 655
XF::runApp() in admin.php at line 13

any help would be appreciated as this is above my pay grade
 
Top