XenTag Importer

XenTag Importer 1.0

No permission to download

dwdmadmac

Active member
Hi Tan,

Now I'm receiving a blank page..

EDIT: Now it's working. I didn't see the finished statement though. Error logged:

ErrorException: Fatal Error: syntax error, unexpected ')' - library/XenTagImporter/Deferred/Thread.php:39

One more question, can I safely uninstall the xentag after the import?
Remove the "( )" in "continue();"

This error will most likely happen if you are running a certain php version, which is 5.4+ I think. This is valid for 5.3 but not any above.
 

Ronal_N7

Member
Hi,

After import, i don't see any tag in thread. It seems not working. I don't know why because it rebuild successful after i fix some code problem above.

Please help.
 

Tan Tran

Well-known member
Hi,

After import, i don't see any tag in thread. It seems not working. I don't know why because it rebuild successful after i fix some code problem above.

Please help.
Hi, please make sure XenTag db tables are existing and also check your XenForo Content Tags settings because this importer checks XenTag tags against those settings when importing.

And you could try this importer - https://xenforo.com/community/resources/by-pix-house-com-importer-for-tinhte-xentag-to-xenforo-1-5.4403/
 

ailys

Member
Bugs and bugs !!!!

Impossible to desinstall this add on which is not working.
If I want to delete it :
Fatal error: Call to undefined method XenForo_Model_Tag::flushTagResultsCache() in /datas/vol2/w4a149377/var/www/esthauto.com/htdocs/library/XenTagImporter/Deferred/Thread.php on line 69

How can I do to delete it ???

Thx.
 

ailys

Member
Please edit this file: XenTagImporter/Deferred/Thread.php

Find:
PHP:
$forum = $forumModel->getForumById($thread['node_id']);
Then replace it with:
PHP:
$forum = $forumModel->getForumById($thread['node_id']);
if (!$forum) {
       continue();
}
Parse error: syntax error, unexpected ')' in /datas/vol2/w4a149377/var/www/esthauto.com/htdocs/library/XenTagImporter/Deferred/Thread.php on line 39
 

Tan Tran

Well-known member
Parse error: syntax error, unexpected ')' in /datas/vol2/w4a149377/var/www/esthauto.com/htdocs/library/XenTagImporter/Deferred/Thread.php on line 39
Something gone wrong after you edited the php files. Try to use the orginal files from the installation package.

Impossible to desinstall this add on which is not working.
If I want to delete it :
Fatal error: Call to undefined method XenForo_Model_Tag::flushTagResultsCache() in /datas/vol2/w4a149377/var/www/esthauto.com/htdocs/library/XenTagImporter/Deferred/Thread.php on line 69
You deactivated the addon while having an incompleted Deferred task. You can see an error message in admin dashboard asking to finish the task.

You need to activate the addon again. And resume the deferred task.
 
Last edited:

ph.d

Member
Hey @Tan Tran, this addon have a problem when import Vietnamese tags! For example Tiếng Việt => Ting Vit, it missing character when import. How to fix it? Thanks
 

Live Free

Active member
Testing this importer after a test 1.5 upgrade and receive the following error when rebuilding to cache:

Code:
Server Error Log
Error Info
ErrorException: Fatal Error: Call to undefined method XenForo_Model_Tag::updateAddUserId() - library/XenTagImporter/Deferred/Thread.php:63
Generated By: admin, A moment ago
Stack Trace
#0 [internal function]: XenForo_Application::handleFatalError()
#1 {main}
Request State
array(3) {
  ["url"] => string(65) "http://www.mysite.com/testinstllation/admin.php?tools/run-deferred"
  ["_GET"] => array(1) {
    ["tools/run-deferred"] => string(0) ""
  }
  ["_POST"] => array(3) {
    ["redirect"] => string(46) "http://www.mysite.com/testinstallation/admin.php"
    ["execute"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
  }
}
Also, does this happen to provide redirects for XenTag urls?
 

MikeMpls

Well-known member
Will this work with any XF 1.5.x (e.g. 1.5.21)? Forum is currently on XF 1.4.0 Beta 2 with XenTag 1.8.4b and thousands of tags?
 
Top