• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

Xenmood Guide.

Shelley

Well-known member
#1
I've installed Xenmoods correctly but the moods are not showing?
.......................................................................................................................................................

First, log into your AdminCP and go to >> User >> Usergroups and select the usergroups you want to allow to view, use and/or both. Normally you've correctly set everything just forgotten to allow the appropriate permission per usergroup.

Scroll down to the bottom upon selecting the usergroup and set accordingly (Screenshot Below)

xenmood_usergroup_permissio.png


A quick way of telling that you've set the moods correctly is by venturing into the AdminCP and under Options you see Moods which you can click and if they are listing correctly and showing it'll be permission based issues (Revert to above).

xenmood_listings.png


If still, the moods are not showing, check that you made the appropriate template edits. (Thread View) uses the hook system so you won't need to worry about this.

You may also want to check whilst in the AdminCP and go to Appearance >> Style Properties scroll down and click on Moods ensuring that the boxes are all checked, or at least, the areas you want the moods showing in so adjust accordingly. (Screenshot Below)

style_properties_moods.png


Just a few tips for others that experience the same issues. Normally, and I've did this myself, I forgot to set the usergroup permissions and left wondering "I did everything correctly" why aren't they showing. The above is normally the reasons.

----------------------------------------------------------------------------------------------

For those of you that want to hide the moods for those that haven't selected a mood replace the top line in the mood_display template with the following code

Code:
<xen:if is="{$canViewMoods} && ({$user.mood_id} || (!{$user.mood_id} && {$visitor.user_id} == {$user.user_id}))">

To move moods to display under user titles, rather than below avatars, follow the instructions (below)

Firstly, you need to disable the template hook. Edit /library/XenMoods/Listener/TemplateHook.php, find (on line 22):

Find:
PHP:
new self($name, $contents, $params, $template);

Replace with:
PHP:
//new self($name, $contents, $params, $template);

Next, edit the message_user_info template.

Find:
HTML:
<div class="avatarHolder"><xen:avatar user="$user" size="m" itemprop="photo" /></div>

Add Before: </div>
HTML:
<xen:if is="@threadShowMood">
	<xen:include template="mood_display" />
</xen:if>

Find:
HTML:
<xen:if hascontent="true"><em class="userTitle" itemprop="title"><xen:contentcheck>{xen:helper userTitle, $user}</xen:contentcheck></em></xen:if>

Add Below:
HTML:
<xen:if is="@threadShowMood">
	<xen:include template="mood_display" />
</xen:if>
The Xenmood Add-on can be found in this thread developed by Dismounted Mood icons designed by Shelley.