Fixed XenForo should set the "Auto-Submitted: auto-generated" header when sending emails

Affected version
2.2.5

Steffen

Well-known member
"Process mails from web applications like e-mail address verification and password reset mails should be tagged as 'automatically submitted' so that mail servers do not respond with 'Out of office' or vacation notification mails." – http://cweiske.de/tagebuch/laravel-notification-autosubmit.htm

I think this applies to all emails sent by XenForo.

Maybe it would make sense to set the non-standard header "Precedence: bulk", too. Afaik it is older and some software might not support "Auto-Submitted" yet.
 

XF Bug Bot

XenForo bug fixer bot
Staff member
Thank you for reporting this issue, it has now been resolved. We are aiming to include any changes that have been made in a future XF release (2.2.6).

Change log:
Add header 'Auto-Submitted: auto-generated' header by default to outgoing emails with the ability to override or unset if needed.
There may be a delay before changes are rolled out to the XenForo Community.
 

Mr E

New member
We are having the same issue with a newly opened forum.

Confirmation emails are not sending. If a new member registers the site says that a confirmation email has been sent, but the new member never receives it. When they use the "resubmit" option, the same problem.

Eventually after several attempts and several hours an auto-generated pop up on the site advises the member to check their account settings. One user was then able to use a different email address that went right through. I've used the run test for outgoing emails and they go right through, but the confirmation emails are not.
 
Top