1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XenForo Server Setup Guide Part 3 (CentOS, OpenLiteSpeed, Percona) (With Pictures!)

An easy to follow quick setup guide for a powerful XenForo server stack. Part 3 of 3

  1. Slavik

    Slavik XenForo Moderator Staff Member

    Slavik submitted a new resource:

    XenForo Server Setup Guide Part 3 (CentOS, OpenLiteSpeed, Percona) (With Pictures!) - An easy to follow quick setup guide for a powerful XenForo server stack. Part 3 of 3

    Read more about this resource...
     
  2. Slavik

    Slavik XenForo Moderator Staff Member

  3. arr0w

    arr0w Member

    Excellent guide and a life saver. Thanks a lot. :)

    If you mentioned it in the guide I missed it, but is there a way to change the default PHPMyAdmin htaccess login from test : test123 to something else?
     
  4. Slavik

    Slavik XenForo Moderator Staff Member

    Just change it to whatever you want :)
     
  5. arms

    arms Active Member

    @Slavik Thank you very much for this guide.

    I've added :
    Code:
    -A INPUT -i lo -j ACCEPT
    -A OUTPUT -o lo -j ACCEPT
    To my IPTable rules and using locally installed HeidiSql through SSH tunnel. It seems much more simpler and secure than installing phpmyadmin. Do you see any downsides?
     
  6. Slavik

    Slavik XenForo Moderator Staff Member

    Does it re-ask you for the password or just doesnt show anything?
     
  7. Slavik

    Slavik XenForo Moderator Staff Member

    Try re-setting up the password protection.

    What version of OLS are you running?
     
  8. Slavik

    Slavik XenForo Moderator Staff Member

    Try downgrading to OLS 1.2.9
     
    vinhtq likes this.
  9. vinhtq

    vinhtq Member

    I have installed Xenforo on subdomain, can you please do me a favor how to dns a record and config it ?
    Thank you very much.
     
  10. Slavik

    Slavik XenForo Moderator Staff Member


    This would be done where ever your domain / nameservers are registered.
     
    vinhtq likes this.
  11. vinhtq

    vinhtq Member

    But I dont know how to register new domain, especially new subdomain to a folder in this TUT. Can you give me some example code in SSH?
     
  12. Slavik

    Slavik XenForo Moderator Staff Member

    This is the hosting part only, the domain registration is done elsewhere at a company like namecheap
     
    vinhtq likes this.
  13. vinhtq

    vinhtq Member

    They said I have to A record to IP server, but I dont know which IP and when domain already DNS, where to add subdomain on server ?
    Plz help me as I am newbie and dont know English very well.
     
  14. Slavik

    Slavik XenForo Moderator Staff Member

    I dont know what your trying to say im afraid.
     
  15. vinhtq

    vinhtq Member

    When I configed my VPS as you told, I want to add more subdomain and domain to VPS, can you give me the command to to this ?
     
  16. Slavik

    Slavik XenForo Moderator Staff Member

    Ah right,

    You would need to create new folders (where the DEFAULT) folder is, then create a new vhost in the LiteSpeed Panel using the folders you just made, and then assign a listener to it.

    I don't have the time to create an in-depth how to do this, but give it a go, see how you manage and post a thread in the server / hosting support forum if your still struggling.
     
    vinhtq likes this.
  17. dotpro

    dotpro Active Member

    Thank you for the guide! What do you use to manage OpenLitespeed with cpanel/whm deployment? I understand there is no integration with cpanel for opensource version.
     

Share This Page