• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not a bug  XenForo not playing well from text pasted from word

Status
Not open for further replies.

Rigel Kentaurus

Well-known member
#1
Test pasted from word has always been an issue, and somehow vBulletin dealt with it. I thought that was just stripped, but I guess it wasn't, and it is only somehow hidden. When I did an import to XenForo, a LOT of that was exposed, in such a way that some of my threads are unreadable.

Check
http://fanficslandia.com/xenforo/index.php?threads/powerpuff-girl-d.7447/
(original: http://fanficslandia.com/showthread.php?t=195684)

and
http://fanficslandia.com/xenforo/in...no-niño-que-salió-de-una-caja-de-cereal.7448/
(original: http://fanficslandia.com/showthread.php?t=195685)


In the first link it is pretty obvious that it came from a Word document. In the second link the text is just plagued by emoticons. I consider this as a bug. Either from XenForo or from the import process.
 

Jake Bunce

XenForo moderator
Staff member
#2
HTML is enabled on your vB forum. That post uses HTML formatting. The problem is that xenForo doesn't currently support HTML posts so the HTML is being exposed. The devs have said that feature may be added in the future, possibly as a HTML BB code.
 

Rigel Kentaurus

Well-known member
#3
HTML is enabled on your vB forum. That post uses HTML formatting. The problem is that xenForo doesn't currently support HTML posts so the HTML is being exposed. The devs have said that feature may be added in the future, possibly as a HTML BB code.
I see, so that is the reason.

I have no idea why HTML is enabled, it is disabled in most other of my forums ...
I have disabled HTML and now the post is showing incorrectly in vBulletin, which is expected. Thanks.
 

Pepelac

Well-known member
#4
Don't paste text from Word, unless it was cleaned from all that sh*t that it adds to html. Or use online services, like http://word2cleanhtml.com/ to clean text.
Wysiwyg editor, that used in XenForo has a button "Paste from Word", but it is disabled.
But as i said, paste text from Word is bad idea.
 

feldon30

Well-known member
#5
Not really sure why it's XenForo's responsibility to clean up the monstrously bad, proprietary code generated by Microsoft Word. When you are in Word, you can Copy as Plain Text.
 

Rigel Kentaurus

Well-known member
#6
Not really sure why it's XenForo's responsibility to clean up the monstrously bad, proprietary code generated by Microsoft Word. When you are in Word, you can Copy as Plain Text.
I cannot say that to 10,000 members, tough ;)
So, yes, it has to be solved at the software level

It is a forum for writers .. they post their stories. They do use .doc for creating them. They could put them as an attachment, most choose to just copy-paste the text. I understand that copying and pasting from word is a bad idea but it is logistically impossible to educate everybody.

Anyhow, I don't think this is a problem with the copy-paste, but rather with the import.
 

feldon30

Well-known member
#7
I'm sure there is a way to re-enable the Paste From Word button which is normally included with TinyMCE but which has been disabled in XenForo.
 

Brogan

XenForo moderator
Staff member
#10
The developers have suggested that HTML within posts might be available in a future release.
So hopefully that will solve your particular problem.
 

feldon30

Well-known member
#11
Yes. But I think, that there isn't way to make users use that button
If they want to paste from Word they will. Is there a WYSIWYG editor out there that automatically strips out the hundreds of proprietary, bogus, nonsense MS Word tags, without stripping out tags the user might be wanting to post, like bbCodes, and HTML tags for instance in a [html] or [code] box?
 

TrevC

Well-known member
#14
just how stupid are your members. If they can't read/comprehend a sticky god help them irl.
Nice attitude. Why bother commenting? Users shouldn't need a sticky to explain why simply pasting content is broken.

Yeah, pasting from Word is strange, but I've seen people do similar things. It's one of those user actions that should "just work", without presenting issues for people or the appearance of the forum. All pasted formatting/fonts should be stripped as a TinyMCE default, IMO.

I fixed some of our issues with pasted content by over-riding all styles in posts. You can force font-size, color, weight, etc, to somewhat clean up the garbage editor output. Just use the !important declaraton in your CSS like:
Code:
.messageText, .messageText *
{
    background: none!important;
    line-height:1.35em!important;
    font-size: 1em!important;
    color: #333!important;
    font-family: "Helvetica Neue", sans-serif!important;
    text-align: left!important;
}
 

cclaerhout

Well-known member
#15
Hop Hop, this is a two years old thread that I've been "popuped" but a member who posted the same question in three or four different threads.
There is now a plugin to fix that. Case is closed.
 
Status
Not open for further replies.