1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 XenForo in temporary server directory

Discussion in 'Installation, Upgrade, and Import Support' started by BassMan, Aug 9, 2013.

  1. BassMan

    BassMan Well-Known Member

    Thank you for links and your time.

    For now I need only one more information:
     
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    The redirects will require .htaccess and can be specific to your install. The community will be more than willing to help you when you are ready.
     
    BassMan likes this.
  3. BassMan

    BassMan Well-Known Member

    Ok, I'm done editing, I've imported content from phpBB with no problems.

    Now I want to move the forum from my temporary folder to my subdomain called forum where the phpBB board is now (ok, I'll move that board first!).
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Archive the phpBB installation.

    Move the XenForo installation.

    Update the Board URL in the ACP to reflect the new path.
     
  5. BassMan

    BassMan Well-Known Member

    Great! Working!

    But how can I remove word forums and threads in URL after my domain?

    Example:

    Now it shows forum.mysite.com/forums/.....

    I want forum.mysite.com/.....
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    You can't remove routes, only change them using route filters.
     
    BassMan likes this.
  7. BassMan

    BassMan Well-Known Member

    Ok, and how to rename for example:

    forum.mysite.com/members/

    How to change word members to something else?
     
  8. Jeremy

    Jeremy XenForo Moderator Staff Member

    Route Filters in the ACP.
     
    BassMan likes this.
  9. Brogan

    Brogan XenForo Moderator Staff Member

  10. BassMan

    BassMan Well-Known Member

    Hi!

    I've added this code to my .htaccess before line </IfModule>, but it is not redirecting.

    Code:
    RewriteCond %{QUERY_STRING} (^|&)t=([0-9]+)(&|$) [NC]
    RewriteRule ^viewtopic\.php$ /threads/%2? [L,R=301,NC]
    RewriteCond %{QUERY_STRING} f=(\d+)$ [NC]
    RewriteRule ^(viewforum\.php|viewtopic\.php)$ /forums/%1? [L,R=301,NC]
    RewriteCond %{QUERY_STRING} (^|&)p=([0-9]+)(&|$) [NC]
    RewriteRule ^viewtopic\.php$ /posts/%2? [L,R=301,NC]
    Well, I hope I understand the redirecting right. When I click on a link in search engine it needs to redirect me to the new board?
     
  11. Jeremy

    Jeremy XenForo Moderator Staff Member

    @mladiucitelj, I've moved your support posts from pre-sales to the installation forums.
     
  12. BassMan

    BassMan Well-Known Member

    Ok, sorry if I posted too much questions in this thread...
     
  13. Jeremy

    Jeremy XenForo Moderator Staff Member

    Not a problem, this is just more appropriate place for the discussion (the post was more of an informative "I've moved it" versus a disciplinary comment).
     
    BassMan likes this.

Share This Page