• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Xenforo db crash issue. Failed to restore

#1
I am unable to restore my xenforo. I've tried restoring the files and mysqldb but no joy. I am having the following error when I ran it on debug mode:

An exception occurred: Access denied for user 'hwbbq_dbforum'@'localhost' (using password: YES) in /home/hwbbq/public_html/community/library/Zend/Db/Adapter/Mysqli.php on line 333

  1. Zend_Db_Adapter_Mysqli->_connect() in Zend/Db/Adapter/Abstract.php at line 315
  2. Zend_Db_Adapter_Abstract->getConnection() in XenForo/Application.php at line 684
  3. XenForo_Application->loadDb()
  4. call_user_func_array() in XenForo/Application.php at line 921
  5. XenForo_Application->lazyLoad() in XenForo/Application.php at line 952
  6. XenForo_Application::get() in XenForo/Application.php at line 1359
  7. XenForo_Application::getDb() in XenForo/Model.php at line 161
  8. XenForo_Model->_getDb() in XenForo/Model/DataRegistry.php at line 138
  9. XenForo_Model_DataRegistry->_getMultiFromDb() in XenForo/Model/DataRegistry.php at line 97
  10. XenForo_Model_DataRegistry->getMulti() in XenForo/Dependencies/Abstract.php at line 144
  11. XenForo_Dependencies_Abstract->preLoadData() in XenForo/FrontController.php at line 127
  12. XenForo_FrontController->run() in /home/hwbbq/public_html/community/index.php at line 13
Please help...
 

Brogan

XenForo moderator
Staff member
#2
That message implies you are using the wrong credentials in config.php for the database.

Check the db name, user name and password are correct.