1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Xenforo and CLoudflare

Discussion in 'XenForo Questions and Support' started by DannyCutts, Sep 16, 2016.

  1. DannyCutts

    DannyCutts Member

    Does anybody run Cloudflare on their forums?
     
  2. SneakyDave

    SneakyDave Well-Known Member

    I run it on a couple of my XenForo forums
     
  3. DannyCutts

    DannyCutts Member

    Does it work ok?
     
  4. SneakyDave

    SneakyDave Well-Known Member

    Sure. If you turn off Rocket Loader, or whatever it's called.

    You also need to make sure your webserver is configured to identify the correct IP of your visitors, or use the XenForo add-on that does that.
     
    Joe Link likes this.
  5. Mark T

    Mark T Active Member

    Do you have a link to that addon?

    I have been experimenting on and off with cloudflare, and I did notice all guests and members on whos online all have cloudflare ips now so i dont use it. I suspect all registration and post ip data would be the same. I cant use that if the case.
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Mark T likes this.
  7. Mark T

    Mark T Active Member

    Still checking the config on cloudfare site.

    Waiting for nameservers to resolve right now.

    Does anyone know of the standard dns setup at cloudflare?

    I just want to get it right, I am new to cf.
     
  8. SneakyDave

    SneakyDave Well-Known Member

    https://xenforo.com/community/resources/solidmean-cloudflare-detect.1595/
     

Share This Page