• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Xenforo and caching

#1
Currently the software is on a VPS and the database in on a shared. I'm looking to speed up things and I enabled xcache on the VPS. What's the next step that I would need to do to use xcache? I've seen a few of the configs that people have used but since the database and forum software are on different server levels I'm not sure how I should go about implementing xcache or if xcache would even be beneficial?
 

Adam Howard

Well-known member
#2
Currently the software is on a VPS and the database in on a shared. I'm looking to speed up things and I enabled xcache on the VPS. What's the next step that I would need to do to use xcache? I've seen a few of the configs that people have used but since the database and forum software are on different server levels I'm not sure how I should go about implementing xcache or if xcache would even be beneficial?
If you're using nginx, I found that the site is faster without cache (go figure, eh?).

For all the fuss I have heard about cache and I have used it always, but recent disabling it made my site faster.
 

Sheratan

Well-known member
#3
Currently the software is on a VPS and the database in on a shared. I'm looking to speed up things and I enabled xcache on the VPS. What's the next step that I would need to do to use xcache? I've seen a few of the configs that people have used but since the database and forum software are on different server levels I'm not sure how I should go about implementing xcache or if xcache would even be beneficial?
Configure your xcache cache, varcache, ttl, etc. Find it on php.ini or xcache.ini. Location? Depends on your OS and the way you install xcache.

http://xcache.lighttpd.net/wiki/XcacheIni

I would suggest you to install xcache admincp to clear your cache manually without restarting php and maintain your cache.
 
#4
I'm an utter newb when it comes to XCache. From research this seems to be what I would put in my config.php file?
$config['cache'] = array(
'enabled' => true,
'frontend' => 'Core',
'frontendOptions' => array(
'caching' => true,
'automatic_serialization' => false,
'cache_id_prefix' => 'you_prefix_',
'lifetime' => 18000
),
'backend' => 'Xcache',
'backendOptions' => array(),
'cacheSessions' => true
);
 
#6
I'd start with the backend cache first
$config['cache']['backend'] = 'xcache';

Xcache default is zero memory allocation. Check your php.ini and adjust it for your environment.