• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

WordPress Display Online Members 1.2.5b

No permission to download

EasyTarget

Well-known member
#1
EasyTarget submitted a new resource:

WordPress Display Online Members (version 1.2.5) - Display what forum members are online in a WordPress widget

Hello All:

This is a WordPress widget that will display who is currently online on your Xenforo forum. Each member name is listed with a link back to the member's profile page.
View attachment 25944

Multiple options:
Modify the css, use PDO or SQL database connection, custom titles, number of members to list, and more.

The widget output can be modified to your specific needs. If you need help send me a message and I will help you modify it.

The widget should work with all versions of...
Read more about this resource...
 

polle

Active member
#2
I just tried this and I got an error.

Code:
Fatal error: Class 'Link' not found in /var/www/vhosts/site.com/httpdocs/wp-content/plugins/eipSoftware/onlinenow/cls/cls_sidebartable.php on line 54
Also in the install instructions it talks about "Last Posts", so I think theres a confusion with another plugin.

How can I fix the error problem ?

Thanks.
 

EasyTarget

Well-known member
#3
How can I fix the error problem ?
Hi Polle:

three things to check.
First:
make sure your directory structure looks like this...
../plugins/
/eipSoftware/​
/onlinenow/​
.....rest of the files​
/shared/​
/cls/​
/cls_htmlelements.php/
....rest of the files​

Second:
Check to make sure the permissions on the files are all set the same.

Third:
In the file cls_sidebartable.php, there is a line that should be commented out that isn't
go to line 50 and you can comment out the line,

PHP:
$guest_count    = 0;
//http://localhost/forums/index.php?online/
$html_Title = new Link(array('href'=>getOnlineUsers::$userOptions['forumDomain'].'index.php?online/',
                'text'=>getOnlineUsers::$userOptions['forumWidgetTitle']));
Or you can re-download the package. I updated the files.
In the instructions; I was copying and pasting the instructions from another widget; forgot to update a couple of lines. My Mistake.

Let me know if you have any more questions.
Thanks


 

polle

Active member
#4
Not working, I redownloaded.

In line 52 I changed this:
Code:
        http://localhost/forums/index.php?online/
to this:

Code:
    //    http://localhost/forums/index.php?online/
I got the same error.

In the error line 54 I have this:

Code:
        $html_Title = new Link(array('href'=>getOnlineUsers::$userOptions['forumDomain'].'index.php?online/',
Thanks.
 

polle

Active member
#8
Ok, I just redownload to try and it seems its working.

The thing I noticed is the users it says that are online. How does the plugin read that ?

In my forum I have 15 users and the widget says 83.

The thing to have in mind here is that I have a gallery that shares users with xenforo and there are 35 users and in wordpress another 25. So the numbers does not match in any way.

It should just show the forum ones ?

Thanks.
 

EasyTarget

Well-known member
#9
The thing I noticed is the users it says that are online. How does the plugin read that ?
the file qry_currentonlineusers.php has the .sql query to determine the online users.
It gets the info from the xf_session_activity table.

You can modify the query to suit your own needs. The query works for my client's needs.
 

EasyTarget

Well-known member
#12
o4/18/2012 an unexpected error was generated
please use the back button to return to the prior page.
Can you provide some more details? the error message should say what file and line number generated the error.
Most likely there is a problem with the configuration screen, either the plugin can't find your forms configuration file OR the plugin can't connect to your database.

Let me know some more info and I can try and help out.
Thanks
 

EasyTarget

Well-known member
#18
Does the wordpress site have to be on the same URL as the forum?
If not, I'm going to check this out tonight :)
Hi Brandon:
The woprdpress implementation doesn't need to be on the same URL as the xenforo.

The only limitation would be that the server that hosts the wordpress installation needs to be able to talk to both databases. I assumed that the database would be available at local host. However with some tweaking you could technically talk to 2 databases located on different servers.
 
#19
Hello,

I'm getting an error on the widget (this is on my dev machine):

At 09/01/2012 21.14.27 an unexpected error was generated.

Please use the back button to return to the prior page.
Warning: mysql_close() expects parameter 1 to be resource, null given in C:\xampp\htdocs\site23\wp-content\plugins\eipSoftware\shared\cls\cls_runquery.php on line 35
Any ideas?

Thanks!