1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Why this error?

Discussion in 'Troubleshooting and Problems' started by ennovations, Jul 10, 2012.

  1. ennovations

    ennovations New Member

    A member posted an intro thread with first post. The second member welcomed. The third member's reply got posted thrice so the thread now contains one intro post & 4 replies but the category homepage shows that the thread contains 2 replies. Now I deleted 2 duplicate replies to make the thread contain 2 unique replies by 2 unique members. The forum index now says that there are zero replies while in fact there are two.

    Whats messing up? Hope I'm clear with the question?
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    The double post is probably due to a spotty connection between client and server. This often causes people to resubmit their post resulting in double posts, and this can cause the thread counters to be wrong.

    The forum and thread counters can be rebuilt by running these options:

    Admin CP -> Tools -> Rebuild Caches
    > Rebuild Thread Information
    > Rebuild Forum Information
  3. ennovations

    ennovations New Member

    Perfect! thanks :)
  4. CyclingTribe

    CyclingTribe Well-Known Member

    I see this from people using mobile devices over 3G - they assume (due to slow response across the mobile network) that their post hasn't been submitted so they press the reply button again (and again and again sometimes). o_O

    I also see this if I make a mistake and give the server a processor/disk intensive task to do during peak times. :oops:
  5. ennovations

    ennovations New Member

    Nope actually I carried the test myself & I clicked on 'Post Reply' only once & I'm darn sure about it. Its just that it got posted thrice dont know why!


Share This Page