1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Weirdest title issues in XenForo

Discussion in 'Troubleshooting and Problems' started by Floren, Sep 21, 2012.

  1. Floren

    Floren Well-Known Member

    I have something really weird happening in XenForo: If I create a thread title with specific keywords on it, the title is completely hidden. For example, as soon I create a thread with keyword "CentOS" on it, the entire title disappears in forumdisplay view:


    As soon I remove the "CentOS" keyword, title shows back like magic. This happens in forumdisplay only, I can see fine the thread title elsewhere. I tried other keywords, the issue happens specifically on "CentOS" keyword only. I'm going to leave the "CentOS" keyword present into title, so you see live what I mean about the thread title. Running a query, the post displays properly the title into database, so is not something related to badly stored data.

    I talked to Mike and he has no idea where the issue could be. This is not a browser cache issue, I get this issue on every single possible or impossible browser. Something is definitely wrong and extremely annoying. I would appreciate your help to solve the puzzle. Thank you.

    Attached Files:

  2. Digital Doctor

    Digital Doctor Well-Known Member

    what about these (in the title):

    Floren likes this.
  3. Russ

    Russ Well-Known Member

    Thinking the obvious and not sure why it would cause that but did you try reverting thread_list_item by chance(if there's any changes made to it)
  4. Floren

    Floren Well-Known Member

    I have no template customizations, everything is stock.
  5. Floren

    Floren Well-Known Member

  6. Digital Doctor

    Digital Doctor Well-Known Member

    My friend had this problem.
    It's a mod_security thing.
    Xenforo doesn't play well with it.

    I bet Cent_OS is fine :)
  7. Floren

    Floren Well-Known Member

    I run Nginx? No mod_security installed. Ya, "Cent_OS" works fine.
    So how do I fix this?
  8. Digital Doctor

    Digital Doctor Well-Known Member

  9. Floren

    Floren Well-Known Member

    Well, I don't have mod_security installed, nor Apache. I have nowhere defined in Nginx a rewrite rule related to the above mentioned keywords so the problem is definitely not related. In fact, I run a minimal install CentOS 6 setup with the strictest number of packages installed on my box.

    I left in place the "CentOS" keyword, so any ninja coders can look at page output. I'm curious if anyone finds a solution.
  10. Digital Doctor

    Digital Doctor Well-Known Member

    Read that thread.
    I know Wireshark helped figure out what the problem was.

    Weird that the same words tftp, nmap, wget give problems just like mod_security.
  11. Floren

    Floren Well-Known Member

    I read it, it states this interesting bug. This is definitely not related to mod_security...
    Can any devs look into it and post a proper solution? Thanks a lot.

    Edit: I noticed that if the keyword is last into thread title, it displays properly in forumdisplay.
  12. Digital Doctor

    Digital Doctor Well-Known Member

    How the hell did you figure that out ! :)

    The plot thickens :)

    The fix I've seen implemented for the mod_security triggers was to rewrite things
    ie. turn all instances of
    tftp to t-f-t-p
    CentOS to Cent_OS
    etc. etc.
  13. Floren

    Floren Well-Known Member

    Try a thread on your forum with one of those keywords at end, it should work.
    Well, as said before... I DON'T run mod_security so it is not relevant to say is related to it. :)

    Edit: confirmed.
    Digital Doctor likes this.
  14. Digital Doctor

    Digital Doctor Well-Known Member

    What about server errors ?
    Do the logs say anything ?
    501 errors ?
    Do you run something analogous to mod_security ?
  15. Floren

    Floren Well-Known Member

    Actually, it is not the keyword position but rather the title string length! Whoa...

    "Keyword wget turns title blank" OK
    "Keyword wget turns title with CentOS keyword blank" FAIL
    "Bug in XenForo: nmap" OK

    There are no errors present into logs, that is the first thing I looked for. Obvious when troubleshooting things, no?
    However, there is someone passionate to check if I have the /forums-open directory on my server:
    Stop repeating "mod_security" and "mod" this or that. :ROFLMAO:
    Clearer than this... it cannot be.
    Digital Doctor likes this.
  16. Digital Doctor

    Digital Doctor Well-Known Member

  17. Floren

    Floren Well-Known Member

    I'm pretty sure is not related to some server dependency, but rather something weird in a JavaScript file.
    Digital Doctor likes this.
  18. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I have seen this exact problem caused by client applications like Norton Internet Security. Did you try a different computer?
  19. Digital Doctor

    Digital Doctor Well-Known Member

    All the problems happened on multiple PCs.
    Including a few of mine.
  20. lazy llama

    lazy llama Well-Known Member

    I'm not seeing this on a test install on Raspbian using nginx, which would indicate it's not a plain nginx or XF issue.


Share This Page