XF 2.1 Vimeo Showcase Embed

MediaSVI

Member
I need to be able to embed Vimeo Showcases in my forum and I can't seem to make it happen. I use the </> Code Insert and select HTML but it does not work.

Here is the code I am using, private is the numbers for the showcase that I did not post.

<div style='padding:56.25% 0 0 0;position:relative;'><iframe src='https://vimeo.com/showcase/private/embed' allowfullscreen frameborder='0' style='position:absolute;top:0;left:0;width:100%;height:100%;'></iframe></div>

Can Vimeo Showcases be embedded in a forum post?

Any help would be greatly appreciated.
 

MediaSVI

Member
I do not understand? There is an insert so I select it.

Screen Shot 2020-09-26 at 10.01.40 AM.png

This opens a selection window and I select HTML


Screen Shot 2020-09-26 at 9.59.43 AM.png

I then paste the Vimeo Showcase embed code and save but it does not work?


Screen Shot 2020-09-26 at 10.00.10 AM.png


The embed code works fine in Wordpress when posting in an HTML block. I do not understand why the INSERT in XenForo has a select to insert HTML and it does not work?
 

MediaSVI

Member
Here is the custom BB code I use for embedding a Vimeo Showcase into a post, works great.


<div style='padding:56.25% 0 0 0;position:relative;'><iframe src='https://vimeo.com/showcase/{text}/embed' allowfullscreen frameborder='0' style='position:absolute;top:0;left:0;width:100%;height:100%;'></iframe></div>


This is what you put in your post [Vimeo] insert Vimeo Showcase number here [/Vimeo]

example [Vimeo]1234567[/Vimeo]
 
Top