1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Users reporting slow responses/double posting

Discussion in 'Troubleshooting and Problems' started by Phil Conway, Jan 20, 2011.

  1. Phil Conway

    Phil Conway Active Member

    Getting complaints about this on my site.

    The symptoms described are: The user will post, but the page doesn't update or displays the "busy" animation in the top-right for more than 30 seconds. If the user presses "Post Reply" again, nothing happens. When they refresh the page, they've posted twice.

    I've taken a quick straw-poll (http://www.nucastle.co.uk/index.php?threads/74142/page-3) and the affected users seem to be running either Google Chrome or Safari.

    Any ideas or suggestions appreciated :)
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  3. Mikey

    Mikey Well-Known Member

    I've experienced this problem myself on my forum, and on wetalk. I enter my post into the box, I click post reply, the loading animation displays, the button fades out, when the button fades back in and the reply isnt posted yet, I click it again, and it posts twice.

    Slow internet connection problem?
     
  4. Phil Conway

    Phil Conway Active Member

    I've replicated the problem on my site, so far I haven't been able to replicate it on this forum.
     
  5. Phil Conway

    Phil Conway Active Member

    I don't think so. I've replicated it using safari at work on our 100mbps link.
     
  6. Decent60

    Decent60 Well-Known Member

    More than likely, you're getting too many jQuery connections to your pages, causing a high amount of memory usage. We had a problem like that on our site, it was due to the DBTech's Shoutbox (I had it display on every page, but since there is no idle time, leaving a page open could severely degrade server performance).
     
  7. Phil Conway

    Phil Conway Active Member

    If that is the case, is there any way to resolve it, or allocate more memory?

    We've got 2GB of RAM on our box, only 400MB is in use.
     
  8. Decent60

    Decent60 Well-Known Member

    Well, just looking at the your webpage externally, the only thing I can see that would cause it is the external sourcing of your jQuery (jquery.min.js), which is loaded up on Google.
    Btw, I had a hard time signing up for it using FireFox 3.6.13. It took about 20 seconds to load, just to tell me that I didn't put the right dates in for the D.O.B :p

    Try switching the jQuery file source to local for 24 hours and see if that doesn't affect the posting/page loading.
     
  9. kingston

    kingston Well-Known Member

    The local jQuery thing helped me out!
     
    AlexandrosD likes this.
  10. Phil Conway

    Phil Conway Active Member

    I had changed it to Google to see if users noticed a difference - they were complaining when it was set to local.

    Changed it back to see if it makes things better...
     
  11. Phil Conway

    Phil Conway Active Member

    No difference I'm afraid :(
     
  12. Phil Conway

    Phil Conway Active Member

    Are there any settings I could change Apache-wise that would prevent this from happening?
     
  13. steven s

    steven s Well-Known Member

    I've had a few double posts myself on our forum.
    How do you switch jQuery to local?
     
  14. Luke F

    Luke F Well-Known Member

    Could try swapping apache for nginx+php-fpm (far lighter and faster)
     
  15. Decent60

    Decent60 Well-Known Member

    AdminCP => Options => Performance => Very last option
     
  16. steven s

    steven s Well-Known Member

    Thank. Looks like it's local by default.
     

Share This Page