• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

User upgrade problem

Jeff Fuqua

Well-known member
I have two upgrades:

1. Monthly Donor
2. Yearly Donor

Both are supposed to put a member into the donor user group. The yearly one works but the monthly one does not. Any ideas? Thanks.


XenForo moderator
Staff member
Impossible to diagnose without further information.

If the annual one works then copy the settings to the monthly one and it should work also.


XenForo moderator
Staff member
Do the members receive an error?
Is the payment taken?
Is there anything in the ACP error log?

Have you confirmed it yourself by purchasing a monthly upgrade?

Jeff Fuqua

Well-known member
I've not tried it myself. Good idea. Will do that now.

The member receive nothing but I do receive confirmation via Paypal of the payment. I don't see anything in the error log.

Jake Bunce

XenForo moderator
Staff member
Check the xf_user_upgrade_log table. Is there any record of the transaction? The record may contain a specific error message if there was a problem. If there is no record of the transaction then make sure the payment completed (in your paypal account). Also check these things:

1) Make sure your board URL is correct:

Admin CP -> Home -> Options -> Basic Board Information -> Board URL

2) Note that the paypal callbacks don't work if your forum is behind a htaccess login.

Or it's possible Paypal simply failed to send the callback. That happens sometimes in which case you can manually upgrade the user in the Admin CP.


The second query here might also help:


It is sometimes possible for group changes to not be applied if the user was previously added to that group.

Jeff Fuqua

Well-known member
1. I have it as "goTitans | a Tennessee Titans Fan Forum". I changed that a while back in the hopes it would gain me a little higher placement on Google. This may be the reason if PayPal is looking for just a url as it did seem to work months ago.

2. I believe I do have .htaccess set to convert those who don't put www. in the url to do that.