• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 User Name/User Title Movement

Brogan

XenForo moderator
Staff member
#2
You can edit the template(s) and move the various divs around.

The FAQ in my signature explains how to identify the page/template you are on.
From there you can usually work out which related template you need to edit.
 
#4
Got it done. Now just need to figure out how to enable signatures. For some reason, we can't find it anywhere and it wasn't auto-enabled.
 
#6
Permissions has everything enabled...but nobody has the ability to edit their signature, only avatar. And preferences has "Show Signatures" automatically enabled for all users.

The problem is there is no where to add a signature. The option is missing entirely despite all of the permissions being enabled/viewable/existing in general, lol.

Stealthy Box Forums.png
 
#8
All of the permissions are set correctly for all users. I double-checked and used the "Analyze Permission" option.

What I'm saying is the Signature option doesn't exist anywhere on my board. It's not even available as an option in the AdminCP to enable/disable. The permissions show it should exist, and preferences show it should exist, but the actual option to make Signatures viewable is completely missing on the back end.

I've tried searching "Signature" in my AdminCP and nothing shows up that would lead to Signatures being able to be edited by users.
 

Brogan

XenForo moderator
Staff member
#9
It's just a permission.
The only other place it exists in the ACP is default user registration values, but that ties in to profile preferences.

If you can provide an ACP login I can take a look.
 
#10
Hey Brogan, I'll send you a convo with details.

I did "Test Permissions" on 3 other users and the Signature option is available to all of them now...so I did something right, lol. However, even though my User Permissions and my Group Permissions is the EXACT same as theirs, I can't see a Signature option on my profile.

It's a punch in the gut.
 

Brogan

XenForo moderator
Staff member
#11
OK, I think I can see the problem ;)

upload_2014-3-13_19-6-52.png

upload_2014-3-13_19-9-23.png

You also have your groups set up all wrong.
See the link in my signature regarding implementing permissions.
 
#14
Got it done. Now just need to figure out how to enable signatures. For some reason, we can't find it anywhere and it wasn't auto-enabled.
Hi! That FAQ that Brogan details shows that the template in question is thread_view - is this correct? I'm not able to find within this template exactly how to move the user name & title above the avatar. Can you elaborate a little on how you did this? Thanks! :)