• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

User Account Upgrades

Ablac

Active member
#1
One of my users bought an upgrade and it didn't update his account i had to manually add it. And ideas why it wouldn't update??
 

Jake Bunce

XenForo moderator
Staff member
#2
Check the xf_user_upgrade_log table. Is there any record of the transaction? The record may contain a specific error message if there was a problem. If there is no record of the transaction then make sure the payment completed (in your paypal account). Also check these things:

1) Make sure your board URL is correct:

Admin CP -> Home -> Options -> Basic Board Information -> Board URL

2) Note that the paypal callbacks don't work if your forum is behind a htaccess login.

Or it's possible Paypal simply failed to send the callback. That happens sometimes in which case you can manually upgrade the user in the Admin CP.
 

Ablac

Active member
#3
Im on my phone right no so please excuse the grammer and spelling.

I have advanced user upgrades installed and checking its transaction log it shows the transaction but it does say "Invalid Business or reciever_email"
 

Ablac

Active member
#4
I checked the email and it wasnt the primary email on the paypal account. Hopefully that was the issue as the upgrade section says to use the primary email :/
 

Ablac

Active member
#5
I changed my Primary Email in paypal, And changed it to the same email on the forums and yet im still getting the same error :/ Think it could be Advanced Upgrades?
 

Ablac

Active member
#6
Sorry For Posting so much but i sorted the issue :)

I called Paypal and they informed me the IPN got disabled :/ Not sure how that happened
But its sorted now :)