1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Uploading consuming alot of Ram.

Discussion in 'Server Configuration and Hosting' started by Skyuser, Aug 6, 2013.

  1. Skyuser

    Skyuser Member

    Guys help me to optimize my VPS for XenForo.
    I have 1 Gb ram 1 Xeon Core.
    Installed forum today. 20 online. This use 100 Mb ram but when 3 members uploading some attachments it tooks around 420 Mb Ram and more
    Using Apache+nginx as front/back-end
    MaxKeepAliveRequests 100
    KeepAliveTimeout 15

    <IfModule prefork.c>
    StartServers 4
    MinSpareServers 5
    MaxSpareServers 10
    ServerLimit 50
    MaxClients 25
    MaxRequestsPerChild 1000

    <IfModule worker.c>
    StartServers 4
    MaxClients 25
    MinSpareThreads 25
    MaxSpareThreads 75
    ThreadsPerChild 25
    MaxRequestsPerChild 1000

    httpd Modules running:

    core_module (static)
    mpm_prefork_module (static)
    http_module (static)
    so_module (static)
    auth_basic_module (shared)
    auth_digest_module (shared)
    authn_file_module (shared)
    authn_alias_module (shared)
    authn_anon_module (shared)
    authn_dbm_module (shared)
    authn_default_module (shared)
    authz_host_module (shared)
    authz_user_module (shared)
    authz_owner_module (shared)
    authz_groupfile_module (shared)
    authz_dbm_module (shared)
    authz_default_module (shared)
    ldap_module (shared)
    authnz_ldap_module (shared)
    include_module (shared)
    log_config_module (shared)
    logio_module (shared)
    env_module (shared)
    ext_filter_module (shared)
    mime_magic_module (shared)
    expires_module (shared)
    deflate_module (shared)
    headers_module (shared)
    usertrack_module (shared)
    setenvif_module (shared)
    mime_module (shared)
    dav_module (shared)
    status_module (shared)
    autoindex_module (shared)
    info_module (shared)
    dav_fs_module (shared)
    vhost_alias_module (shared)
    negotiation_module (shared)
    dir_module (shared)
    actions_module (shared)
    speling_module (shared)
    userdir_module (shared)
    alias_module (shared)
    substitute_module (shared)
    rewrite_module (shared)
    proxy_module (shared)
    proxy_balancer_module (shared)
    proxy_ftp_module (shared)
    proxy_http_module (shared)
    proxy_ajp_module (shared)
    proxy_connect_module (shared)
    cache_module (shared)
    suexec_module (shared)
    disk_cache_module (shared)
    cgi_module (shared)
    version_module (shared)
    rpaf_module (shared)
    php5_module (shared)
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    All post attachments? Or just images? Try using a different image library if one is available:

    Admin CP -> Home -> Options -> Attachments -> Default Image Processor
  3. Skyuser

    Skyuser Member

    @Jake Bunce Yes. When uploading images! I have php GD and ImageMagick PECL.
    Should i install ImageMagick PECL and enable it?
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Yeah, install ImageMagick and enable it in the Admin CP. It might be a problem with your image library, and changing image libraries is one way to test it.

    When uploading an image as a post attachment the image library is used to resize it.

Share This Page