1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrading PHP

Discussion in 'Server Configuration and Hosting' started by XxUnkn0wnxX, Feb 2, 2014.

  1. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    well when it comes to it. i use cpanel managed server, easyapache and i don't see PHP 5.3.3 in there


    so is 5.4.x stable enough for xenforo 1.3?

    and will most/all add ones work with php 5.4.x?

    and i am guessing when xenforo 1.3.x comes out the stable release i disable all add ones? and then re enable after upgrade?

    i don't need to worry about back ups as my server makes a back up every day for me.. data bases and the user directory every thing
  2. MattW

    MattW Well-Known Member

    5.5.X is stable enough for XF ;)

    # php -v
    PHP 5.5.8 (cli) (built: Feb  1 2014 09:24:22)
    Copyright (c) 1997-2013 The PHP Group
    Zend Engine v2.5.0, Copyright (c) 1998-2013 Zend Technologies
        with Zend OPcache v7.0.3-dev, Copyright (c) 1999-2013, by Zend Technologies
    bortrenamo and Tracy Perry like this.
  3. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    but it say it experimental...

    i have many add ones. does 5.5x support them all? is it backwards compatible? because i have over 40-50+ add ones
  4. MattW

    MattW Well-Known Member

    It's only "experimental" in Cpanel. 5.5 has been in stable tier since June 2013, and many people use it. I've got over 40 addons installed, and they all work fine. If you find one that doesn't, just re-build easyapache and downgrade to 5.4.X
  5. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    ok so i am on 1.2.4 now wont upgrade till stable 1.3.x, so xenforo 1.2.4 is ok with php 5.5.x?
  6. MattW

    MattW Well-Known Member

    Yes, it works fine on 5.5.X
  7. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    looks like highest for me is 5.4.x because i have APC installed and i need that
  8. MattW

    MattW Well-Known Member

    You could switch to Xcache which works with PHP 5.5, but you'd need to build it yourself as 3.0.3 in EasyApache doesn't work. You'd need 3.1.0.

    Or, going with PHP 5.5 has the built in ZendOPCache that you can use.
    Null likes this.
  9. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    i already have x cache but php 5.5 removed most of my custom extentions i had installed on the sever which i needed. and i prefer APC its been better for me.. + i use FastCGI, APC, Xcache, ZendOPCache i have them all installed
  10. Null

    Null Well-Known Member

    If you're that worried, go with 5.4.24 (old stable), however... PHP 5.5.8 isn't experimental and is now widely used in production environments.

    You don't need to use APC if you use PHP 5.5.8 as ZendOPCache is built into the 5.5.x core (just make sure it's enabled in php.ini)... there's also no benefit to have both APC and ZendOPCache installed, it'll just add overhead.

    APC's support can be questioned; it hasn't been updated (stable) since May 2011.
    MattW likes this.
  11. bortrenamo

    bortrenamo Member

    To help you decide...

    Meeasly 64MB for opcache and still got 14MB left!
    It's a small site though.

    Remove host in attachment
    Last edited: Feb 2, 2014
    MattW likes this.
  12. HittingSmoke

    HittingSmoke Active Member

    PHP 5.4 is perfectly fine. Most people actually go with the previous stable branch. Most support, still gets security updates, etc. I use PHP 5.4 because APC doesn't support PHP 5.5 and 5.5 doesn't support opcode caching through uWSGI. Go with 5.4. You'll have no problems.
  13. p4guru

    p4guru Well-Known Member

    grab APC 3.1.15-dev build it runs PHP 5.5 fine for me with Centmin Mod stack http://centminmod.com/phpfpm.html#php55 :)
  14. HittingSmoke

    HittingSmoke Active Member

    Meh. There isn't anything in PHP 5.5 that makes me want to run an unstable build of APC. PHP 5.4 is perfectly secure and stable.

Share This Page