• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Upgrading PHP

XxUnkn0wnxX

Active member
#1
well when it comes to it. i use cpanel managed server, easyapache and i don't see PHP 5.3.3 in there



so is 5.4.x stable enough for xenforo 1.3?

and will most/all add ones work with php 5.4.x?

and i am guessing when xenforo 1.3.x comes out the stable release i disable all add ones? and then re enable after upgrade?

i don't need to worry about back ups as my server makes a back up every day for me.. data bases and the user directory every thing
 

MattW

Well-known member
#2
well when it comes to it. i use cpanel managed server, easyapache and i don't see PHP 5.3.3 in there



so is 5.4.x stable enough for xenforo 1.3?

and will most/all add ones work with php 5.4.x?

and i am guessing when xenforo 1.3.x comes out the stable release i disable all add ones? and then re enable after upgrade?

i don't need to worry about back ups as my server makes a back up every day for me.. data bases and the user directory every thing
5.5.X is stable enough for XF ;)

Code:
# php -v
PHP 5.5.8 (cli) (built: Feb  1 2014 09:24:22)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2013 Zend Technologies
    with Zend OPcache v7.0.3-dev, Copyright (c) 1999-2013, by Zend Technologies
 

XxUnkn0wnxX

Active member
#3
5.5.X is stable enough for XF ;)

Code:
# php -v
PHP 5.5.8 (cli) (built: Feb  1 2014 09:24:22)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2013 Zend Technologies
    with Zend OPcache v7.0.3-dev, Copyright (c) 1999-2013, by Zend Technologies
but it say it experimental...

i have many add ones. does 5.5x support them all? is it backwards compatible? because i have over 40-50+ add ones
 

MattW

Well-known member
#4
but it say it experimental...

i have many add ones. does 5.5x support them all? is it backwards compatible? because i have over 40-50+ add ones
It's only "experimental" in Cpanel. 5.5 has been in stable tier since June 2013, and many people use it. I've got over 40 addons installed, and they all work fine. If you find one that doesn't, just re-build easyapache and downgrade to 5.4.X
 

XxUnkn0wnxX

Active member
#5
It's only "experimental" in Cpanel. 5.5 has been in stable tier since June 2013, and many people use it. I've got over 40 addons installed, and they all work fine. If you find one that doesn't, just re-build easyapache and downgrade to 5.4.X
ok so i am on 1.2.4 now wont upgrade till stable 1.3.x, so xenforo 1.2.4 is ok with php 5.5.x?
 

MattW

Well-known member
#8
looks like highest for me is 5.4.x because i have APC installed and i need that
You could switch to Xcache which works with PHP 5.5, but you'd need to build it yourself as 3.0.3 in EasyApache doesn't work. You'd need 3.1.0.

Or, going with PHP 5.5 has the built in ZendOPCache that you can use.
 

XxUnkn0wnxX

Active member
#9
You could switch to Xcache which works with PHP 5.5, but you'd need to build it yourself as 3.0.3 in EasyApache doesn't work. You'd need 3.1.0.

Or, going with PHP 5.5 has the built in ZendOPCache that you can use.
i already have x cache but php 5.5 removed most of my custom extentions i had installed on the sever which i needed. and i prefer APC its been better for me.. + i use FastCGI, APC, Xcache, ZendOPCache i have them all installed
 

Null

Well-known member
#10
If you're that worried, go with 5.4.24 (old stable), however... PHP 5.5.8 isn't experimental and is now widely used in production environments.

You don't need to use APC if you use PHP 5.5.8 as ZendOPCache is built into the 5.5.x core (just make sure it's enabled in php.ini)... there's also no benefit to have both APC and ZendOPCache installed, it'll just add overhead.

APC's support can be questioned; it hasn't been updated (stable) since May 2011.
 
#11
To help you decide...
Capture.PNG

Meeasly 64MB for opcache and still got 14MB left!
It's a small site though.

[Edit]
Remove host in attachment
 
Last edited:
#12
looks like highest for me is 5.4.x because i have APC installed and i need that
PHP 5.4 is perfectly fine. Most people actually go with the previous stable branch. Most support, still gets security updates, etc. I use PHP 5.4 because APC doesn't support PHP 5.5 and 5.5 doesn't support opcode caching through uWSGI. Go with 5.4. You'll have no problems.