Upgrade from Xenforo 1.5.8. to 2.2.8

James_Husum

New member
I'm working with author Holly Lisle and we're trying to upgrade and move her current forum. The forum currently runs on Xenforo 1.5.8.

The site is being upgraded to a newer version of PHP. We need to be able to move the threads and private messages from the old forum over to the new installation. I've found importers for Xenforo 2.X versions of the software but nothing for before that.

Is there a good migration path we can follow, or do I need to find someone that has (or can create) an importer to go from 1.5.8 to 2.2.8?

Thanks in advance.
 

Scandal

Active member
I've found importers for Xenforo 2.X versions of the software but nothing for before that.
Yes that's correct.
1. You make a clean installation of a xenForo 2. This forum will not have other users than you (admin) and also no forum categories and posts.
2. Then you install the 2.x importers addon on this clean forum board.
3. You run the import. On the import process you will be asked for several things like: the database name of your xF1.5 forum, the url of the attachments folder etc.
4. Now the empty xF2 installation of step #1 above will have the data of your xF1 -> you have a ready xF2 board!

  • Do some rehearsal before you run the import on your production site.
  • Create a backup before any action.
 

James_Husum

New member
You can't import from XF1 into XF2.

The correct way to do it is to upgrade the existing installation and then PHP, as per the post above.

So, we can't do an upgrade from the old Xenforo 1.5.8 system at all then? Does that mean we have to scrap the threads / conversations / etc. we've built up and just start over from scratch?
 

James_Husum

New member
OK. We currently have the new version (2.2.8) it set up on a test domain to make sure that everything will work after we upgrade PHP on the server. Forgive me for being dense, but I want to make sure that I understand the process. Instead of doing a fresh install of 2.2.8 on the test server we should do an upgrade on the existing 1.5.8 installation on the current server so that we can retain our current threads / messages / etc., using the instructions in the link you provided. Correct?
 

Brogan

XenForo moderator
Staff member
Instead of doing a fresh install of 2.2.8 on the test server we should do an upgrade on the existing 1.5.8 installation on the current server so that we can retain our current threads / messages / etc., using the instructions in the link you provided. Correct?
Correct.

Test the process first by duplicating your existing XF1 installation and upgrading that.

Once you are comfortable with the process you can do it on the production site.

 

James_Husum

New member
OK, another question. I followed the steps in the 'how to duplicate a live site to use as a test site' instructions you linked to in your previous post. We got the database set up, imported the data into it from the current live site, created a new directory on the server to copy the files into, copied all the files into the new directory, updated the library/config.php file (we're using Xenforo 1.5.8 currently) to use the new database information, logged into the admin area and updated the Board Title and URL under Options, and finally updated the config.php file to include the suggested code. As far as I know, the hosting company is not using a cache system on the site.

After all this, when I go to the url for the test forum, I'm getting a blank page (https://hwc1.net/forum/).

Am I perhaps missing something? Or any other ideas on what I may have done wrong to not get the forum to show up?
 

Masetrix

Well-known member
After all this, when I go to the url for the test forum, I'm getting a blank page (https://hwc1.net/forum/).

Am I perhaps missing something? Or any other ideas on what I may have done wrong to not get the forum to show up?
Use: admin-site login... and make the necessary settings here, especially for the paths...
In addition, the PHP version used is too new for this version of XF, you should still use php7.0 or 7.2 here.
See:
Fatal error: Uncaught ErrorException: array_key_exists(): Using array_key_exists() on objects is deprecated. Use isset() or property_exists() instead in /var/www/html/hw/hwc1.net/forum/library/Zend/Registry.php:206 Stack trace: #0 /var/www/html/hw/hwc1.net/forum/library/Zend/Registry.php(206): XenForo_Application::handlePhpError() #1 /var/www/html/hw/hwc1.net/forum/library/Zend/Registry.php(183): Zend_Registry->offsetExists() #2 /var/www/html/hw/hwc1.net/forum/library/XenForo/Helper/File.php(276): Zend_Registry::isRegistered() #3 /var/www/html/hw/hwc1.net/forum/library/XenForo/Error.php(78): XenForo_Helper_File::getInternalDataPath() #4 /var/www/html/hw/hwc1.net/forum/library/XenForo/Application.php(378): XenForo_Error::unexpectedException() #5 [internal function]: XenForo_Application::handleException() #6 {main} thrown in /var/www/html/hw/hwc1.net/forum/library/Zend/Registry.php on line 206
 
Last edited:

James_Husum

New member
Use: admin-site login... and make the necessary settings here, especially for the paths...
In addition, the PHP version used is too new for this version of XF, you should still use php7.0 or 7.2 here.
See:

Yes, changed everything in the admin area.

It's the PHP that is giving me the problems. OK, good to know. Part of what we're doing is having to move to a new server with a newer version of PHP on it, and test the upgrade process.

I just wanted to make sure I hadn't missed anything else.

Thanks!
 
Top