1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Upgrade 1.4.6 > 1.4.8 error

Discussion in 'Installation, Upgrade, and Import Support' started by TacTicToe, Jun 23, 2015.

  1. TacTicToe

    TacTicToe Member

    Code:
    Failed to get controller response and reroute to error handler (XenForo_Install_Controller_Upgrade::action)
    An exception occurred: Constant DISABLEIPDENY already defined in /home/www/web3241/web3241u1/html/library/config.php on line 16
    
    XenForo_Application::handlePhpError()
    define() in config.php at line 16
    require() in XenForo/Application.php at line 616
    XenForo_Application->loadConfig() in XenForo/Application.php at line 265
    XenForo_Application->loadDefaultData() in XenForo/Install/Controller/Abstract.php at line 10
    XenForo_Install_Controller_Abstract->_preDispatchFirst() in XenForo/Controller.php at line 304
    XenForo_Controller->preDispatch() in XenForo/FrontController.php at line 346
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /home/www/web3241/web3241u1/html/install/index.php at line 18
    Never had this issue before. My forums are currently locked out due to an impending update.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    This could be a firewall issue.
    Try adding this to library/config.php:

    Code:
    define('DISABLEIPDENY', true);
     
  3. TacTicToe

    TacTicToe Member

    Nvm fixed it by deleting line 16 from my config.

    It was actually a firewall issue.

    Thanks
     

Share This Page