1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Unable to create new forum node

Discussion in 'Troubleshooting and Problems' started by ibenick, Jun 21, 2012.

  1. ibenick

    ibenick Active Member

    I am no longer able to create a new forum node on my site, I just get a Mysqli statement execute error about the post_rules_url field. I can't think of anything I've installed since the last time I was able to do it with no problems. Any ideas?

    This is what I get:

    The following error occurred:

    Mysqli statement execute error : Field 'post_rules_url' doesn't have a default value
    1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    3. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
    4. Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1591
    5. XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1580
    6. XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1381
    7. XenForo_DataWriter->save() in XenForo/ControllerAdmin/Forum.php at line 115
    8. XenForo_ControllerAdmin_Forum->actionSave() in NodesAsTabs/ControllerAdmin/AllNodes.php at line 7
    9. NodesAsTabs_ControllerAdmin_AllNodes->actionSave() in XenForo/FrontController.php at line 310
    10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    11. XenForo_FrontController->run() in /home/ibenick/public_html/forum/admin.php at line 13
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    There is no "post_rules_url" field in the default software. The NodesAsTabs addon is referenced in the error. You can try disabling that addon but that shouldn't be causing this. Try disabling any other addons you have installed to isolate the problem.
     
  3. ibenick

    ibenick Active Member

    Just went and tried disabling add-ons one-by-one with no success. Tried disabling every add-on all at once and still can't create a new forum.
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Does the file check pass?

    Admin CP -> Tools -> File Health Check
     
  5. ibenick

    ibenick Active Member

    It didn't.This is what it came back with:

    Potential Problems

    1. library/Ragtek/SLXT/Config.phpFile does not contain expected contents.
    Showing 1 of 1 items

    I disabled the Ragtek plugin and the file health check comes back clean but I still get the error when trying to create a forum. :mad:
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That's weird. I can take a look if you give me admin and FTP access.
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I misread the error. It is an error returned by MySQL, not the datawriter.

    This is a problem with the Merc_EnforcePostRules addon. Without going into the technical details... that addon has some problems. Since you are not currently using it (it is disabled) I suggest you simply uninstall it. That will remove the offending columns in the database which should fix the error.

    If you choose to enable it again then you need to contact the author for an update. I see a few problems with that addon. xf_forum.post_rules_url and xf_forum.post_rules_overlay should have default values in the schema to avoid this error when the addon is disabled. And Merc_EnforcePostRules_ControllerAdmin_Forum::actionSave needs to call the parent function.
     
  8. ibenick

    ibenick Active Member

    As usual, Jake knows the answer! That fixed the problem. Thanks so much for your help again, Jake!
     

Share This Page