1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Trash XenPorta Sidebar

How to dump XenPorta sidebar in favor of Widget Framework

  1. silence

    silence Well-Known Member

    silence submitted a new resource:

    Trash XenPorta Sidebar - How to dump XenPorta sidebar in favor of Widget Framework

    Read more about this resource...
    SneakyDave likes this.
  2. AyKuT

    AyKuT Member

    After I trashed all XenPorta sidebar widgets and activated Widget Framework, number of queries for home page increased from 11 to 32. Have you faced similar result?
  3. silence

    silence Well-Known Member

    Nope I have less than 10 queries on my homepage with the WF sidebar. How many queries do you have on your forum main page?
  4. Degrinch

    Degrinch Active Member

    Love the last Code box! Got a good chuckle out of that.
    silence likes this.
  5. Degrinch

    Degrinch Active Member

    Perhaps I can get some assistance in this thread, similar conversation pertaining to the bd widget framework addon... I have an issue with the widgets displaying without impacting the template layout. I am current on all aspects (xen and the widget framework addon).
  6. silence

    silence Well-Known Member

    I'm confused. What's the issue?
  7. Degrinch

    Degrinch Active Member

    Whats to be confused about? :)

    When I create a widget, in any area of my website, the theme display is altered (overlaps other menus, widgets, or the widget fails to display properly.

    An example: would be when I create a small ad widget within the a node display, it does not expand the node frame to display the widget properly. This is the case regardless of the theme I use. :)

    Any suggestions?
  8. silence

    silence Well-Known Member

    Can you link me to the issue, so I can see what can be done, please?
  9. Degrinch

    Degrinch Active Member

    Is there a time period I need wait for some sort of cache update when creating a new widget? I have left these active for a bit to see if this is the case, but there is no change.
  10. silence

    silence Well-Known Member

    Not usually.
  11. Degrinch

    Degrinch Active Member

    Ok... wtf? Now it's showing properly. I deactivated and then re activated the plugin and it seems to be ok now. I had to set up new widgets, the old ones wouldn't show up. But it appears to be working . . .
  12. toodlez

    toodlez Active Member

    Is this working / useful in XF1.3.2 with the latest version of XenPorta?

    Lemminator likes this.
  13. silence

    silence Well-Known Member

    It should be!
  14. Nvkodde

    Nvkodde Member

    is there a way to have the widgets appear in positions other than sidebar? (i.e Top-Right).
  15. MsJacquiiC

    MsJacquiiC Well-Known Member

    Good question. How to position or maybe style the css so it's positioned in top-right instead of the sidebar?

  16. Trying to dump xenPorta but I get this error when I follow your guide

    Invalid position specified: EWRporta_ArticleView. The position must be one of three types: "all", "template_name" or "hook:hook_name".
  17. silence

    silence Well-Known Member

    That may mean the template doesn't exist. If you are using xenporta2 the steps here may be slightly different. You would have to find the template names yourself.

Share This Page