• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Trash XenPorta Sidebar

Trash XenPorta Sidebar

silence

Well-known member
#1
silence submitted a new resource:

Trash XenPorta Sidebar - How to dump XenPorta sidebar in favor of Widget Framework

XenPorta is a widely-used addon that is essential for those who want a complete article management system for XF. However, it comes with an annoying sidebar feature that is completely overshadowed by Widget Framework.

This tutorial will tell you how to dump that sidebar feature completely in favor of Widget Framework.

Now this is pretty easy to do, and requires zero changes to any code. All this requires is changing a few options in the Admin Control Panel.
So let's begin :D

First, you don't...
Read more about this resource...
 
#2
After I trashed all XenPorta sidebar widgets and activated Widget Framework, number of queries for home page increased from 11 to 32. Have you faced similar result?
 

silence

Well-known member
#3
After I trashed all XenPorta sidebar widgets and activated Widget Framework, number of queries for home page increased from 11 to 32. Have you faced similar result?
Nope I have less than 10 queries on my homepage with the WF sidebar. How many queries do you have on your forum main page?
 

Degrinch

Active member
#5
Perhaps I can get some assistance in this thread, similar conversation pertaining to the bd widget framework addon... I have an issue with the widgets displaying without impacting the template layout. I am current on all aspects (xen and the widget framework addon).
 

silence

Well-known member
#6
Perhaps I can get some assistance in this thread, similar conversation pertaining to the bd widget framework addon... I have an issue with the widgets displaying without impacting the template layout. I am current on all aspects (xen and the widget framework addon).
I'm confused. What's the issue?
 

Degrinch

Active member
#7
Whats to be confused about? :)

When I create a widget, in any area of my website, the theme display is altered (overlaps other menus, widgets, or the widget fails to display properly.

An example: would be when I create a small ad widget within the a node display, it does not expand the node frame to display the widget properly. This is the case regardless of the theme I use. :)

Any suggestions?
 

silence

Well-known member
#8
Whats to be confused about? :)

When I create a widget, in any area of my website, the theme display is altered (overlaps other menus, widgets, or the widget fails to display properly.

An example: would be when I create a small ad widget within the a node display, it does not expand the node frame to display the widget properly. This is the case regardless of the theme I use. :)

Any suggestions?
Can you link me to the issue, so I can see what can be done, please?
 

Degrinch

Active member
#9
Is there a time period I need wait for some sort of cache update when creating a new widget? I have left these active for a bit to see if this is the case, but there is no change.
 

Degrinch

Active member
#11
Ok... wtf? Now it's showing properly. I deactivated and then re activated the plugin and it seems to be ok now. I had to set up new widgets, the old ones wouldn't show up. But it appears to be working . . .
 
#16
Trying to dump xenPorta but I get this error when I follow your guide


Position:
Invalid position specified: EWRporta_ArticleView. The position must be one of three types: "all", "template_name" or "hook:hook_name".
 

silence

Well-known member
#17
Trying to dump xenPorta but I get this error when I follow your guide


Position:
Invalid position specified: EWRporta_ArticleView. The position must be one of three types: "all", "template_name" or "hook:hook_name".
That may mean the template doesn't exist. If you are using xenporta2 the steps here may be slightly different. You would have to find the template names yourself.
 

Commodore

Active member
#19
POSITION: EWRporta_ArticleView, EWRporta_Portal, forum_list

This does not work in xenporta 2.

Here is the ERROR popup window:

Position:
Invalid position specified: EWRporta_ArticleView. The position must be one of three types: "all", "template_name" or "hook:hook_name".

Did Jaxel change this so we couldn't eliminate his sidebar???