• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Too many connections error?

#1
Every once in a while I get an error on my site. Can anyone tell me what is causing this and how I might be able to prevent it? Thanks.


An exception occurred: Too many connections in /home/rivalfo1/public_html/library/Zend/Db/Adapter/Mysqli.php on line 333

  1. Zend_Db_Adapter_Mysqli->_connect() in Zend/Db/Adapter/Abstract.php at line 315
  2. Zend_Db_Adapter_Abstract->getConnection() in XenForo/Application.php at line 730
  3. XenForo_Application->loadDb()
  4. call_user_func_array() in XenForo/Application.php at line 973
  5. XenForo_Application->lazyLoad() in XenForo/Application.php at line 1004
  6. XenForo_Application::get() in XenForo/Application.php at line 1609
  7. XenForo_Application::getDb() in XenForo/Model.php at line 161
  8. XenForo_Model->_getDb() in XenForo/Model/DataRegistry.php at line 138
  9. XenForo_Model_DataRegistry->_getMultiFromDb() in XenForo/Model/DataRegistry.php at line 97
  10. XenForo_Model_DataRegistry->getMulti() in XenForo/Dependencies/Abstract.php at line 147
  11. XenForo_Dependencies_Abstract->preLoadData() in XenForo/FrontController.php at line 127
  12. XenForo_FrontController->run() in /home/rivalfo1/public_html/index.php at line 13
 

Brogan

XenForo moderator
Staff member
#4
You can try asking your host to increase the limit, but if it's due to other users on the same server or a limit cap, as mentioned, there's not much you can do other than to switch servers/packages/hosts.
 

DFI

Active member
#5
You can try asking your host to increase the limit, but if it's due to other users on the same server or a limit cap, as mentioned, there's not much you can do other than to switch servers/packages/hosts.
what exactly should i ask my host ? i am on a VPS and frequently getting this error on my website.
 

Tracy Perry

Well-known member
#6
what exactly should i ask my host ? i am on a VPS and frequently getting this error on my website.
To increase the max connections settings in my.cnf (the SQL configuration file).
max_connections = XXX where XXX is a reasonable # of connections (I use 500 which is overkill, but my server has more than adequate memory).