1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

to call method UnnamedClass.handleEvent

Discussion in 'Troubleshooting and Problems' started by tenants, Aug 3, 2011.

  1. tenants

    tenants Well-Known Member

    I get this every now and then when trying to create or edit a post (both on my forum and on this forum):

    Permission denied for <hxxp://uuu.exampleforum.com> to call method UnnamedClass.handleEvent

    I notice it when running firebug. When I get this error, it takes a long while to create/edit the post. If you're not using firebug, then you will probably only feel an unusual hang "20 or 30 seconds"... anyone know what to do to reduce this
    In fact, I just got the error when creating this post and editing it....
    It makes xenforo feel slower that it really is, it seem to occur on the request:

    jquery.min.js (line 141)
    GET http://xenforo.com/community/posts/240252/edit-inline?&_xfRequestUri=/community/threads/to-call-method-unnamedclass-handleevent.18568/&_xfNoRedirect=1&_xfToken=9561,1312408149,ce11f0b41afaa6f40ff20c9120700ea64fac21d9&_xfResponseType=json

    Params:
    _xfNoRedirect 1
    _xfRequestUri /community/threads/to-call-method-unnamedclass-handleevent.18568/
    _xfResponseType json
    _xfToken 9561,1312408149,ce11f0b41afaa6f40ff20c9120700ea64fac21d9

    I've noticed there were 2 GET request. Both had exactly the same params, one was successful, one wasnt... So my 1st thoughts are that this is a race condition / timing / queing issue
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    There are already a couple of bug reports related to Firebug.

    Does it do it in Chrome or IE?
     
  3. tenants

    tenants Well-Known Member

    No, I tried 30 edit and saves and didn't see it in chrome.

    I'll try to turn off firebug in FF and find out if I can identify the hang
     
  4. tenants

    tenants Well-Known Member

    Yup, it seems to be a Firebug only issue. Thanks for letting me know this has been raised.

    Is this something out of xenforo's range to fix. No Fix / Defer?
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    I spoke with Mike about it yesterday.

    It's essentially a Firebug bug but he may be able to do something about it.
     
  6. tenants

    tenants Well-Known Member

    I think this was the thing that was putting me off from buying xenforo at first.
    I noticed the hangs, since I almost always use firebug. Most forum users wont, but the people that buy forums will often use dev tools.
    If anything, it's worth fixing to not put off potential clients, but its not a must fix for forum users (I doubt that many people outside of dev/web designers play around with Firebug)
     

Share This Page