1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Timestamp off since server move

Discussion in 'Troubleshooting and Problems' started by Nudaii, May 30, 2012.

  1. Nudaii

    Nudaii Well-Known Member

    I recently moved gardenerscorner.co.uk from a texas server to a uk one, the server time is correct however the posts timestamp is off by about 10 hours and i am unsure why.

    Any else ever encounter this?
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Make sure your timezone is correct for you:


    You can debug the clock by adding this code to the templates:

    Admin CP -> Appearance -> Templates -> PAGE_CONTAINER

    Add this code to the top:

    {xen:datetime $serverTime, 'absolute'}
    Now every forum page will show the date and time (in your user's time zone). If the date and time is wrong then you need to ask your host or server admin to fix it.

    There is no easy way to fix the dates for existing posts. You might consider turning off your forum until the clock is fixed.
  3. Learner

    Learner Member

    Please also mention if TOP means in the body section or head section or before the start of the <html> tags ??
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member


    Admin CP -> Appearance -> Templates -> PAGE_CONTAINER

    {xen:datetime $serverTime, 'absolute'}
    <!DOCTYPE html>
    <html id="XenForo" lang="{$visitorLanguage.language_code}" dir="{$visitorLanguage.text_direction}" class="Public {xen:if {$visitor.user_id}, 'LoggedIn', 'LoggedOut'} {xen:if {$sidebar}, 'Sidebar', 'NoSidebar'}" xmlns:fb="http://www.facebook.com/2008/fbml">
    <xen:hook name="page_container_head">
    	<meta charset="utf-8" />
    	<xen:if is="{$requestPaths.fullBasePath}">
    		<base href="{$requestPaths.fullBasePath}" />
    		<script><xen:comment>/* Chrome bug and for Google cache */</xen:comment>
    			var _b = document.getElementsByTagName('base')[0], _bH = "{xen:jsescape $requestPaths.fullBasePath}";
    			if (_b && _b.href != _bH) _b.href = _bH;
    	<title><xen:if is="{$title}">{xen:raw $title} | {$xenOptions.boardTitle}<xen:else />{$xenOptions.boardTitle}</xen:if></title>
    	<noscript><style>.JsOnly { display: none !important; }</style></noscript>
    	<link rel="stylesheet" href="css.php?css=xenforo,form,public&amp;style={xen:urlencode $_styleId}&amp;dir={$visitorLanguage.text_direction}&amp;d={$visitorStyle.last_modified_date}" />
    	{xen:helper ignoredCss, {$visitor.ignoredUsers}}
    	<xen:include template="google_analytics" />
    	<xen:include template="page_container_js_head" />
    	<link rel="alternate" type="application/rss+xml" title="{xen:phrase rss_feed_for_x, 'title={$xenOptions.boardTitle}'}" href="{xen:link forums/-/index.rss}" />
    	<xen:if is="{$pageDescription.content} AND !{$pageDescription.skipmeta} AND !{$head.description}"><meta name="description" content="{xen:string wordTrim, {xen:helper stripHtml, {xen:raw $pageDescription.content}}, 200}" /></xen:if>
    	<xen:if is="{$head}"><xen:foreach loop="$head" value="$headElement">{xen:raw $headElement}</xen:foreach></xen:if>
    Learner likes this.
  5. Learner

    Learner Member

    Thanks a TON @jake bunce :D

Share This Page