• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Three Server Errors on two different sites

Brent W

Well-known member
#1
Saw these three errors pop up on two sites

Code:
Error Info
ErrorException: Undefined index: language_id - library/XenForo/Visitor.php:490
Generated By: Unknown Account, Today at 4:41 AM
Stack Trace
#0 /home/rwdcoupe/public_html/library/XenForo/Visitor.php(490): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/rwdcoupe/...', 490, Array)
#1 /home/rwdcoupe/public_html/library/XenForo/Visitor.php(444): XenForo_Visitor->setVisitorLanguage(0)
#2 /home/rwdcoupe/public_html/library/XenForo/Session.php(270): XenForo_Visitor::setup(false, Array)
#3 /home/rwdcoupe/public_html/library/XenForo/Controller.php(291): XenForo_Session::startPublicSession(Object(Zend_Controller_Request_Http))
#4 /home/rwdcoupe/public_html/library/XenForo/Controller.php(304): XenForo_Controller->_setupSession('Errornotfound')
#5 /home/rwdcoupe/public_html/library/XenForo/FrontController.php(336): XenForo_Controller->preDispatch('Errornotfound', 'XenForo_Control...')
#6 /home/rwdcoupe/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#7 /home/rwdcoupe/public_html/index.php(13): XenForo_FrontController->run()
#8 {main}
Request State
array(3) {
  ["url"] => string(34) "http://www.rwdcoupe.com/posts/4979"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
Code:
Error Info
ErrorException: Undefined index: properties - library/XenForo/Dependencies/Public.php:308
Generated By: Unknown Account, Today at 4:41 AM
Stack Trace
#0 /home/rwdcoupe/public_html/library/XenForo/Dependencies/Public.php(308): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/rwdcoupe/...', 308, Array)
#1 /home/rwdcoupe/public_html/library/XenForo/FrontController.php(551): XenForo_Dependencies_Public->preRenderView(Object(XenForo_ControllerResponse_Error))
#2 /home/rwdcoupe/public_html/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_Error), Object(XenForo_ViewRenderer_HtmlPublic), Array)
#3 /home/rwdcoupe/public_html/index.php(13): XenForo_FrontController->run()
#4 {main}
Request State
array(3) {
  ["url"] => string(34) "http://www.rwdcoupe.com/posts/4979"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
Code:
Error Info
ErrorException: Argument 2 passed to XenForo_Application::mapMerge() must be of the type array, boolean given, called in /home/rwdcoupe/public_html/library/XenForo/Dependencies/Public.php on line 309 and defined - library/XenForo/Application.php:1048
Generated By: Unknown Account, Today at 4:41 AM
Stack Trace
#0 /home/rwdcoupe/public_html/library/XenForo/Application.php(1048): XenForo_Application::handlePhpError(4096, 'Argument 2 pass...', '/home/rwdcoupe/...', 1048, Array)
#1 /home/rwdcoupe/public_html/library/XenForo/Dependencies/Public.php(309): XenForo_Application::mapMerge(Array, false)
#2 /home/rwdcoupe/public_html/library/XenForo/FrontController.php(551): XenForo_Dependencies_Public->preRenderView(Object(XenForo_ControllerResponse_Error))
#3 /home/rwdcoupe/public_html/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_Error), Object(XenForo_ViewRenderer_HtmlPublic), Array)
#4 /home/rwdcoupe/public_html/index.php(13): XenForo_FrontController->run()
#5 {main}
Request State
array(3) {
  ["url"] => string(34) "http://www.rwdcoupe.com/posts/4979"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
 

Brent W

Well-known member
#2
Same error on different site:

Code:
Error Info
ErrorException: Undefined index: language_id - library/XenForo/Visitor.php:490
Generated By: Unknown Account, Today at 4:39 AM
Stack Trace
#0 /home/shottalk/public_html/library/XenForo/Visitor.php(490): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/shottalk/...', 490, Array)
#1 /home/shottalk/public_html/library/XenForo/Visitor.php(444): XenForo_Visitor->setVisitorLanguage(0)
#2 /home/shottalk/public_html/library/XenForo/Session.php(270): XenForo_Visitor::setup(false, Array)
#3 /home/shottalk/public_html/library/XenForo/Controller.php(291): XenForo_Session::startPublicSession(Object(Zend_Controller_Request_Http))
#4 /home/shottalk/public_html/library/XenForo/Controller.php(304): XenForo_Controller->_setupSession('Errornotfound')
#5 /home/shottalk/public_html/library/XenForo/FrontController.php(336): XenForo_Controller->preDispatch('Errornotfound', 'XenForo_Control...')
#6 /home/shottalk/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#7 /home/shottalk/public_html/index.php(13): XenForo_FrontController->run()
#8 {main}
Request State
array(3) {
  ["url"] => string(114) "http://www.shottalk.com/threads/obituary-john-bretz-bravo-rip-%E2%80%93-%E2%80%9Cassclench-forever%E2%80%9D.23146/"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}