Thousands of notices an hour: Request is not a GET request. Do not cache.

Alfa1

Well-known member
#1
I am getting thousands of these an hour in my error log:
2017-05-26 15:39:31.928 [NOTICE] [xx.xx.xx.xxx:41929:HTTP2-17] [STDERR] Request is not a GET request. Do not cache.

Does anyone have an idea what this is or how it may be resolved?

I do run redis cache on Litespeed + mariaDB. Redis is giving me a lot of problems. I dont know if it is related.
@MattW @eva2000 @Michael A.
 

Tracy Perry

Well-known member
#2
If you are using LiteSpeed, I'd try contacting their support as that really looks more like a LS error than anything else (the formatting appears to be LS as it's similar to when I used OLS).
Are you using any of LiteSpeed's native caching?
 

Tracy Perry

Well-known member
#4
Since you are paying for it and it includes support (I believe also telephone support?)
Are you using LXSCF?
LSCache can also sometimes have issues that weren't planned.... but it's going to take someone who actually uses LSWS extensively or their support to answer this. I don't use OLS any longer and due to issue with it didn't even contemplate LSWS since I can use nginx at the CLI (no dependency on panel integration).
 
#5
@Alfa1 did you ever manage to get this fixed?

I was getting the same error every second and it was gone when I disabled the LSCache plugin. So now I'm trying to find a fix so I can re-enable it.
 

Alfa1

Well-known member
#6
The fix I applied is to remove Litespeed. Litespeed needs to add better functionality for Xenforo.
I should have done that a lot sooner. What you can do is contact the owner and ask her if they are willing to fix this in the very near future.
 
Last edited:
Top