XF 2.1 This site can’t be reached for connected accounts

Nuno

Well-known member
Hi

For some unknown reason I'm getting this errors when login via connected accounts:

Code:
This site can’t be reached The webpage at https://www.example.com/connected_account.php might be temporarily down or it may have moved permanently to a new web address.
ERR_INVALID_RESPONSE
or

Code:
The webpage at https://www.example.com/connected_account.php?state=123 might be temporarily down or it may have moved permanently to a new web address.
ERR_INVALID_RESPONSE
In the nginx error logs I get a 404 error but the file is there

Any ideia why?
 

robdog

Well-known member
Running into a similar issue but can't seem to find this header being set anywhere. Checked the logs and it doesn't appear to be outputting anything in there as well. Any points as to where I could check next? Thanks.
 

Nuno

Well-known member
Hi

In my case the problem was related to Xon's Redis add-on using persistent connections with different DB for pages, css and system cache.


Changing to one DB only and with this update, things are running smoothly without problems.
 

robdog

Well-known member
Yup that fixed it. Enabling caching caused the issue. As soon as I disabled it, all my connected accounts started working. I'll check out that addon, thanks for the update.

EDIT: I didn't have redis installed, I was using memcache. Once that was disabled in the config, everything worked.
 

Nuno

Well-known member
So in your case you're using memcached with one db for cache, pages and css?
 

robdog

Well-known member
So in your case you're using memcached with one db for cache, pages and css?
Yes, correct. I initially had it as an array with just one value. I switched it to a non-array version, but that didn't matter. Very interesting problem I am running into ...
 
Top